Dell.DFS.Agent.WinService (Dell Foundation Services) May Cause High Memory Usage During Normal Operation

Summary: Information about Dell.DFS.Agent.WinService (Dell Foundation Services) using a large amount of memory.

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms

Task Manager shows Dell.DFS.Agent.WinService with high memory usage.

Cause

No cause information is available.

Resolution

High Memory Usage During Normal Operation

You may encounter a situation where your Dell computer experiences high memory usage while no demanding applications are running on the computer. Research has shown that the Dell Foundation Services application (Dell.DFS.Agent.WinService) may be the cause of this spike in memory usage.

The Dell Foundation Services application facilitates several important service functions and is a required component of the following Dell applications:

  • Dell Update
  • Dell Help & Support
  • Product Registration
  • SupportAssist
  • Dell Data Services

Affected versions of Dell Foundation Services include:

  • 1.0.262.0
  • 1.1.333.0
  • 2.0.39.0
  • 3.3.xxxxx and after (possibly affected)

You can verify if Dell Foundation Services is installed with these steps:

  • Verify memory usage with Task Manager (CTRL+SHIFT+ESC hotkey).
  • Verify the installed version with Control Panel -> Programs and Features.

Inspiron, XPS, Vostro, Venue Pro, Alienware, Precision, OptiPlex, and Latitude computers and tablets that have Windows 7, 8, or 8.1 can run this application.


Solution

Download the latest version of Dell Foundation Services from: Dell Drivers & Downloads

Note: This is an application of critical importance, and Dell Technologies recommends that it remain installed and current.

If you must uninstall and reinstall the application, do the following:

  1. Uninstall the current version of Dell Foundation Services from Programs and Features. Type Programs in the Search Bar then select Programs and Features from the menu that appears.
  2. After uninstalling Dell Foundation Services, verify that the C:\Program Files\Dell\Dell Foundation Services folder does not exist. If it does, manually delete the folders and files in this folder and the Dell Foundation Services folder before reinstalling Dell Foundation Services.
  3. Reboot the computer.
  4. Install the latest version of Dell Foundation Services and the high memory usage issue should be resolved.

Back to Top

Article Properties
Article Number: 000141566
Article Type: Solution
Last Modified: 13 Aug 2025
Version:  5
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.