Dell USB-C and Thunderbolt Docks (WD15, TB16, TB18DC, and D6000 Series) - BIOS Settings and Driver Installation for Troubleshooting
Summary: This article guides you through the installation and basic troubleshooting process for Dell USB Type-C and Thunderbolt Docking Stations WD15, TB16, TB18DC, and the Dell Universal Docking Station (D6000 Series). ...
Symptoms
Most problems when using a USB-C or Thunderbolt Docking Station can be solved by installing the latest BIOS, firmware, and drivers. There are up to nine software components that must be installed depending on the model of the Docking Station.
Follow the instructions in sections 1 and 2 carefully to ensure that the software is installed correctly. Then, follow the instructions in section 3 to configure the BIOS settings for your computer.
Table of Contents
Cause
No cause information is available.
Resolution
1. Updating Docking Station to Resolve Problems
WD15, TB16, TB18DC Updates
When troubleshooting a Docking Station problem. Dell Technologies recommends manually downloading and installing updates from the Dell Drivers & Downloads page. This ensures that all required software is installed, and the latest versions are used.
- Remove the Docking Station USB-C or Thunderbolt cable from the computer.
- Unplug AC power from the Docking Station.
- Drain any remaining power to the Docking Station by holding the power button for 30 seconds.
- Plug AC power into the Docking Station.
- Plug the USB-C or Thunderbolt cable back to the computer.
Windows Operating System and Dell Driver Updates:
- Manually download and update the Docking Station firmware from the Dell Drivers & Downloads page.
The Docking Station must remain connected to the computer during the update. Power cycle the Docking Station once the firmware has been updated. (See instructions for the reset procedure above.) - Run Windows Update to ensure that the operating system is up to date.
- Run SupportAssist (all models), or Dell Command | Update (Precision, XPS, and Latitude) or Dell Update (Vostro, Inspiron, and G-Series) to update the computer BIOS and drivers for both the computer and dock. Drivers can also be manually downloaded and installed. (Table 1.) These computer BIOS (the computer reboots when running the BIOS update), drivers, and the drivers for the dock can be downloaded from the Dell Support Website. (The USB Audio jack driver only applies to docks with 3.5 mm ports.)
Table 1. WD15, TB16, and TB18DC Docking Station Drivers and Firmware.
| Dock Drivers and Firmware | Notes |
|---|---|
| Realtek USB Audio | |
| Realtek USB GBE Ethernet Controller Driver | |
| WD15/TB16/TB18DC Firmware Update Utility | |
| ASMedia USB eXtensible Host Controller Driver | Only for the TB16 or TB18DC |
| System Drivers and Firmware | |
| Intel Thunderbolt Controller Firmware Update Utility |
|
| Intel Thunderbolt Controller Driver |
|
| Intel UHD Graphics Driver | Required even if the computer has discrete graphics. |
| BIOS | |
| Windows Operating System Updates | Run Windows Update. |
- The dock must be connected to the computer to run the firmware update.
- Power cycle the dock once the firmware has been updated. (See instructions above)
- Test the Docking Station to see if the issues are resolved.
If the issues persist, confirm that the BIOS settings are correct: Important BIOS Settings
Dell Universal Docking Station (D6000 Series) Updates
For the Dell Universal Docking Station (D6000 Series), download and install the following drivers and firmware:
- The system BIOS (the computer reboots).
- The DisplayLink driver from the DisplayLink Page
.
- The D6000 firmware update from the Dell Drivers & Downloads Page.
2. Important BIOS Settings
The necessary BIOS settings are similar for all USB Type-C Docking Stations. See the individual notes in the following instructions.
Reboot your computer and press the F2 multiple times when the Dell logo appears. In the BIOS, proceed as follows:
- Browse to System Configuration and then to USB-Configuration.
- Select the options Enable USB Boot Support and Enable External USB Port.
- Browse to Dell Type-C Dock Configuration and select Always Allow Dell Docks.
- Under System Configuration, browse to USB PowerShare and activate this option.
- Browse to Thunderbolt Adapter Configuration, and select Enable Thunderbolt Technology Support, Enable Thunderbolt Adapter Boot Support and Enable Thunderbolt Adapter Preboot Modules.
- In the same category, select Security Level - No Security.
- Now browse to POST Behavior and Fastboot. Select Thorough.
- On the bottom right, click the Apply button to save the changes made. Exit the BIOS by clicking the Exit button.
3. Advanced Troubleshooting Links
General Information about the Docking Stations:
- How to Use and Troubleshoot Dell Docking Station WD15
- Dell Universal Docking Station (D6000 Series) User Guide
- What is MAC Address pass through?
Troubleshooting:
- Dell Business Dock WD15, Dell Thunderbolt Dock TB16, and Dell Precision Dual USB-C Thunderbolt Dock TB18DC Legacy Support
- How to Use and Troubleshoot Dell Docking Station WD15
- How to Use and Troubleshoot Dell Thunderbolt Dock TB16
- Dell Universal Dock (D6000 series) system charging limitations
- Kaby Lake systems with USB Type-C DP only (non-ThunderBolt) connections using WD15 or DS1000 may have blanking external video.
- Driver Installation Guide for Dell Thunderbolt Docking Station WD19TB/WD19TBS
- Driver Installation Guide for Dell Performance Docking Station WD19DC/WD19DCS