SC Series: Adjusting Storage Profiles may result in errors while using SCOS 7.1.20, 7.2.11, or 7.2.30 with Deduplication or Compression
Summary: Excessive "Invalid previous cost" messages in the Storage Center system logs and volumes using Deduplication or Compression does not have data move to the desired location after making a Storage Profile change. ...
Symptoms
This alert pertains to SCOS versions 7.1.20, 7.2.10, 7.2.11, and 7.2.30. It contains specific information related to system features and/or functionality.
Notification:
Dell EMC has identified a software issue that can cause data to not move to the desired location. This is after a Storage Profile change is made to volumes that utilizes Deduplication or Compression. This issue will causes excessive "Invalid previous cost" messages in the Storage Center system logs which could lead to an increased frequency of the system sending SupportAssist information back to Dell Technologies.
Affected versions:
SCOS versions 7.1.20, 7.2.10, 7.2.11, and 7.2.30
Cause
A software issue is causing data to not move to the desired location.
Resolution
Workaround:
There are three possible work arounds for this issue.
- Copy Mirror Migrate (CMM) the volume(s) to new volume(s) and then set the desired Storage Profile on the new volume(s). Note: This requires the original data to be rehydrated during the CMM process and space should be verified.
- Adjust the Storage Profile back to the original Storage Profile and then rehydrate the volume by disabling deduplication and compression. Once the volume has been rehydrated, you can set the desired Storage Profile and enable Deduplication or Compression again.
- Revert the Storage Profile changes made on the volume(s) using Deduplication and / or Compression back to the original Storage Profile. When available, upgrade to a SCOS version where the issue is resolved. Then change to the desired Storage Profile.
Resolution:
This issue is resolved in SCOS versions 7.1.30, 7.2.31, 7.2.40, and 7.3.1.