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Article Number: 000140512


Unable to log in to vSphere Client using Windows session credentials with an account with multiple group memberships.

Article Content


Symptoms


 
Article Summary:

This article provides information on possible cause and how to troubleshoot when You are unable to log in to vSphere Client using Windows Session Credentials with an account with multiple group memberships.



Environment:

  • VMware vSphere 5.5

Symptoms:

  • You are unable to log in to vSphere Client when you select Use Windows session credentials.
  • You are able to log in to vSphere Client by manually entering user credentials.
  • You are able to log in to the vSphere Web Client using Windows session credentials and by manually entering user credentials.
  • This issue occurs when you log in with an account with multiple group memberships in Active Directory or OpenLDAP directory.
  • The viclient-#-0000.log file (located at: C:\Users\username\AppData\Local\VMware\vpx\) contains entries similar to:

    [viclient:Critical:M: 6] YYYY-MM-DD 10:39:30.213 Connection State[psivmc001.pshosting.intranet]: Disconnected
    [viclient:SoapMsg :M: 6] YYYY-MM-DD 10:39:30.213 Attempting graceful shutdown of service ...
    [viclient:SoapMsg :M: 6] YYYY-MM-DD 10:39:30.215 Pending Invocation Count: 0
    [viclient:SoapMsg :M: 6] YYYY-MM-DD 10:39:30.216 Graceful shutdown of service: Success
    [ :Error :M: 6] YYYY-MM-DD 10:39:30.223 Error occured during login
    VirtualInfrastructure.Exceptions.LoginError: The server 'vCenter_Server_FQDN' took too long to respond. (The command has timed out as the remote server is taking too long to respond.)
    at VirtualInfrastructure.LoginMain.Process(BackgroundWorker worker, DoWorkEventArgs e)
    at VirtualInfrastructure.LoginWorkerImpl.Worker_DoWork(Object sender, DoWorkEventArgs e)
    ...
    at System.ComponentModel.BackgroundWorker.WorkerThreadStart(Object argument)
    VirtualInfrastructure.Exceptions.RequestTimedOut: The request failed because the remote server 'psivmc001.pshosting.intranet' took too long to respond. (The command has timed out as the remote server is taking too long to respond.)

Cause:

This issue occurs if the vSphere Client experiences a time out when it queries an account with multiple group memberships in Active Directory or OpenLDAP.

Resolution:

To work around this issue, increase the Client Connection Timeout setting in vSphere Client.

To increase the Client Connection Timeout setting:

  1. Log in to vCenter Server using the vSphere Client.

  2. Go to the Administration menu and click vCenter Server Settings.

  3. Click Timeout Settings.

  4. In the Normal Operations field, type 60.

  5. Click OK.

  6. Exit the vSphere Client and log back in using Windows session credentials.



Reference: Unable to log in to vSphere Client using Windows Session Credentials with an account with multiple group memberships (2062992) 
 

Article Properties


Affected Product

PowerEdge

Last Published Date

21 Feb 2021

Version

3

Article Type

Solution