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SourceOne Email Management does no deduplicate Microsoft Exchange Online (o365) journaled messages

Summary: When archiving Microsoft Exchange Online (o365) journaled messages, messages may not be deduplicated.

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Symptoms

When Microsoft Exchange Online (o365) is configured with Rule Based Journaling, SourceOne Email Management may not deduplicate those messages during SourceOne Journaling ingestion.

The same messages can be seen ingested into SourceOne with different SourceOne MessageID values.

In on premise Microsoft Exchange servers, the same Rule Base Journaling messages are properly deduplicated during SourceOne Journaling ingestion.

No errors are logged in the EMC event logs or the ExJBJournal.exe.log trace logs.

Cause

During Microsoft Exchange Online (o365) Rule Based Journaling, multiple copies of the same messages can be routed to the same Journaling mailbox.

The issue is that the PR_SEARCH_KEY in each copy of the message is different. SourceOne uses the PR_SEARCH_KEY property on a message as part of its algorithm to generate a unique SourceOne MessageID.

Although the messages may appear the same, because the PR_SEARCH_KEY is different, SourceOne identifies these messages as different and as a result generates a different unique SourceOne MessageID.

The PR_SEARCH_KEY property can be viewed using the MFCMAPI utility.

Resolution

In order to identify why multiple copies of the same messages in the Journaling mailbox have different PR_SEARCH_KEY property values, please contact Microsoft Technical Support.

As a workaround, use Microsoft Exchange SMTP Journaling instead of Rule Based Journaling. For more information on configuring Microsoft Exchange SMTP Journaling to work with SourceOne Email Management, please review the SourceOne Email Management Installation Guide at https://dell.com/support.

Affected Products

SourceOne Email Management
Article Properties
Article Number: 000182806
Article Type: Solution
Last Modified: 08 Mar 2022
Version:  5
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