SourceOne Email Management. Сбой при повторном индексировании/перестроении больших томов (> 2 Гбайт) в хранилище S3
Сводка: Большие тома объемом более 2 Гбайт, которые находятся в хранилище S3, не удается скачать для повторного индексирования.
Данная статья применяется к
Данная статья не применяется к
Эта статья не привязана к какому-либо конкретному продукту.
В этой статье указаны не все версии продуктов.
Симптомы
Большие тома объемом более 2 Гбайт, которые находятся в хранилище S3, не удается скачать для повторного индексирования.
Тем не менее, том, размер которого меньше 2 Гбайт, будет скачан и может быть проиндексирован.
В журналах ExAsElasticSearchIdxObj.exe.log можно просмотреть следующие файлы:
Тем не менее, том, размер которого меньше 2 Гбайт, будет скачан и может быть проиндексирован.
В журналах ExAsElasticSearchIdxObj.exe.log можно просмотреть следующие файлы:
|CoES1S3Access::AddHeader|VERBOSE|Added header <Range:bytes=2144338329--2145386087>|CoES1S3Access.cpp(904)| |CoES1S3Access::ReadObjectAsFile|VERBOSE|Retrieving next chunk from S3 - <bytes=2144338329--2145386087>...|CoES1S3Access.cpp(1327)| |CoES1S3Access::GetURL|VERBOSE|URL = <http://s3address:80/s3-bucket/20211209194831.emx>|CoES1S3Access.cpp(882)| |CoES1S3Access::S3Request|VERBOSE|S3Request - URL = <http://s3address:80/s3-bucket/20211209194831.emx>|CoES1S3Access.cpp(1954)| |CoES1S3Access::S3Request|VERBOSE|curl global init code = <0>|CoES1S3Access.cpp(1961)| |CoES1S3Access::S3Request|VERBOSE|Adding <5> HTTP Headers|CoES1S3Access.cpp(1980)| |CoES1S3Access::S3Request|VERBOSE|Adding HTTP Header = <Host:s3address>|CoES1S3Access.cpp(1984)| |CoES1S3Access::S3Request|VERBOSE|Adding HTTP Header = <Date:Mon, 06 Jun 2022 13:41:48 GMT>|CoES1S3Access.cpp(1984)| |CoES1S3Access::S3Request|VERBOSE|Adding HTTP Header = <User-Agent:APN/1.0 EMC/1.0 SourceOne/7.4>|CoES1S3Access.cpp(1984)| |CoES1S3Access::S3Request|VERBOSE|Adding HTTP Header = <Content-Type:application/octet-stream>|CoES1S3Access.cpp(1984)| |CoES1S3Access::S3Request|VERBOSE|Adding HTTP Header = <Authorization:AWS s3-u-sourceone:XXXXXXXXXXXXXXXXXXXXX=>|CoES1S3Access.cpp(1984)| |CoES1S3Access::S3Request|VERBOSE|Adding <1> dynamic HTTP Headers|CoES1S3Access.cpp(1993)| |CoES1S3Access::S3Request|VERBOSE|Adding HTTP Header = <Range:bytes=2144338329--2145386087>|CoES1S3Access.cpp(1997)| |CoES1S3Access::S3Request|VERBOSE|URL = <<http://s3address:80/s3-bucket/20211209194831.emx>|CoES1S3Access.cpp(2009)| |CoES1S3Access::S3Request|VERBOSE|HTTP Method = <GET>|CoES1S3Access.cpp(2095)| |CoES1S3Access::S3Request|VERBOSE|Curl Result Code = <18>|CoES1S3Access.cpp(2107)| |CoES1S3Access::S3Request|VERBOSE|HTTP request error. HTTP status code '18', error description 'transfer closed with 2249406925 bytes remaining to read'.|CoES1S3Access.cpp(2115)| |CoES1S3Access::S3Request|ERROR|HTTP Error occurred - HTTP Status Code [18]. (0x860427DC)|CoES1S3Access.cpp(2117)| |CoES1S3Access::ReadObjectAsFile|VERBOSE|S3Request() failed - hr = <0x860427dc>; Response = <transfer closed with 2249406925 bytes remaining to read>.|CoES1S3Access.cpp(1333)| |CoES1S3Access::ReadObjectAsFile|ERROR|HTTP Error occurred - HTTP Status Code [328058832]. (0x860427DC) HTTP Error occurred - HTTP Status Code [18]. (0x860427DC) [ExAsElasticIdxObj.exe, CoES1S3Access.cpp(2117).CoES1S3Access::S3Request] |CoES1S3Access.cpp(1336)|
Range:bytes=2144338329--2145386087 последняя строка, прочитанная перед сбоем.
Причина
Эта проблема вызвана дефектом программного обеспечения.
Разрешение
Эта проблема решена в пакетах исправлений (HBB) или пакетах обновления версии выше 7.2.12.0026.
Пакеты исправлений и пакеты обновления можно скачать на сайте https://www.dell.com/support. Выберите «Drivers and Downloads» для доступа к необходимому программному обеспечению.
* Обратите внимание, что оперативные исправления доступны только для самых новых версий исправлений или пакетов обновления продукта, которые были доступны на момент решения этой проблемы.
** Обратите внимание, что пакеты исправлений (HBB) нужно устанавливать в правильном порядке, чтобы ВСЕ исправления были правильно применены.
*** Обратите внимание, что всегда рекомендуется выполнять модернизацию до последней версии выпуска SourceOne, пакета обновления и комплекта Hot Fix, чтобы убедиться, что все текущие проблемы будут устранены, включая проблему, описанную выше.
Пакеты исправлений и пакеты обновления можно скачать на сайте https://www.dell.com/support. Выберите «Drivers and Downloads» для доступа к необходимому программному обеспечению.
* Обратите внимание, что оперативные исправления доступны только для самых новых версий исправлений или пакетов обновления продукта, которые были доступны на момент решения этой проблемы.
** Обратите внимание, что пакеты исправлений (HBB) нужно устанавливать в правильном порядке, чтобы ВСЕ исправления были правильно применены.
*** Обратите внимание, что всегда рекомендуется выполнять модернизацию до последней версии выпуска SourceOne, пакета обновления и комплекта Hot Fix, чтобы убедиться, что все текущие проблемы будут устранены, включая проблему, описанную выше.
Затронутые продукты
SourceOne Email ManagementПродукты
SourceOne for File SystemsСвойства статьи
Номер статьи: 000200420
Тип статьи: Solution
Последнее изменение: 02 Jun 2025
Версия: 8
Получите ответы на свои вопросы от других пользователей Dell
Услуги технической поддержки
Проверьте, распространяются ли на ваше устройство услуги технической поддержки.