Dell VNX: Unable to connect to Unisphere GUI after Java update (User Correctable)

Summary: After updating Java to latest version, Unisphere may stop connecting properly.

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms

Java starts up but the Unisphere login window is never shown.

Cause

Oracle changed Java to disable TLSv1 and TLSv1.1 by default. Both algorithms are still required by VNX Unisphere to properly open its GUI. This issue has first been observed on Java version 1.8.0_291, but it may also occur with other versions. 

Resolution

Steps to re-enable TLSv1 and TLSv1.1:

1. Go to the Java path "lib\security" folder (eg. "C:\Program Files (x86)\Java\jre1.8.0_291\lib\security").

2. Open file java.security with admin rights.

3. Search for this parameter jdk.tls.disabledAlgorithms

4. Edit line to remove TLSv1 and TLSv1.1

    Before
    jdk.tls.disabledAlgorithms=SSLv3, TLSv1, TLSv1.1, RC4, DES, MD5withRSA

    After
    jdk.tls.disabledAlgorithms=SSLv3, RC4, DES, MD5withRSA

5. Save file.

6. Clear browser's cache and cookies.

7. Relaunch browser and try opening Unisphere again. It should work fine.

Affected Products

VNX/VNXe, VNX1 Series, VNX2 Series

Products

VNX5100, VNX5200, VNX5300, VNX5400, VNX5500, VNX5600, VNX5700, VNX5800, VNX7500, VNX7600, VNX8000
Article Properties
Article Number: 000202925
Article Type: Solution
Last Modified: 05 Jan 2023
Version:  2
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