Integrated Data Protection Appliance RUCK : Les vérifications vCenter échouent en raison de l’arrêt du service applmgmt

Résumé: Rapid Upgrade Checker (RUCK) échoue sur validate_vc_password_expiry, validate_vc_gateway, vc_hostname_check ou validate_vsan.

Cet article concerne Cet article ne concerne pas Cet article n’est associé à aucun produit spécifique. Toutes les versions du produit ne sont pas identifiées dans cet article.

Symptômes

RUCK échoue sur DP4400 lors de la vérification des éléments suivants :

validate_vc_password_expiry

validate_vc_gateway

vc_hostname_check

Sur les modèles de plus grande taille, RUCK échoue lors de la vérification des éléments suivants :

validate_vsan
 
Capture d’écran de l’état de redondance de mise à niveau en échec
Capture d’écran de l’état de redondance en cas d’échec de mise à niveau supplémentaire

Cause

Cela est dû au fait que applmgmt ne s’exécute pas sur le vCenter.

root@dpappliance-vcsa [ ~ ]# service-control --status --all
Stopped:
 applmgmt vmcam vmware-imagebuilder vmware-mbcs vmware-netdumper vmware-rbd-watchdog vmware-updatemgr vmware-vcha vsan-dps
Running:
 lwsmd pschealth vmafdd vmcad vmdird vmdnsd vmonapi vmware-analytics vmware-certificatemanagement vmware-cis-license vmware-cm vmware-content-library vmware-eam vmware-perfcharts vmware-pod vmware-postgres-archiver vmware-rhttpproxy vmware-sca vmware-sps vmware-statsmonitor vmware-sts-idmd vmware-stsd vmware-topologysvc vmware-vapi-endpoint vmware-vmon vmware-vpostgres vmware-vpxd vmware-vpxd-svcs vmware-vsan-health vmware-vsm vsphere-client vsphere-ui

Ce service peut être arrêté de lui-même, ou plusieurs services peuvent être arrêtés en raison de certificats vCenter expirés. 

Résolution

  1. Connectez-vous àvCenter en tant qu’utilisateur root
  2. Exécutez le shell (si vous obtenez l’invite de commande > )
  3. Exécutez la commande suivante pour confirmer que l’application applmgmt est arrêtée
service-control --status --all
  1. Exécutez la commande suivante pour démarrer applmgmt :
service-control --start applmgmt
  1. Exécutez la commande suivante pour confirmer que applmgmt est en cours d’exécution :
service-control --status --all
 
Capture d’écran des commandes en cours d’exécution
  1. Exécutez à nouveau l’outil RUCK et confirmez que la vérification préalable a réussi pour les échecs mentionnés :
Capture d’écran de l’état de redondance de mise à niveau réussie

Informations supplémentaires

Cet article s’applique uniquement si le service applmgmt n’est pas en cours d’exécution. Les échecs de vérification ci-dessus peuvent être dus à d’autres problèmes.

Produits concernés

PowerProtect DP4400, Integrated Data Protection Appliance Family, Integrated Data Protection Appliance Software
Propriétés de l’article
Numéro d’article: 000206249
Type d’article: Solution
Dernière modification: 27 Mar 2025
Version:  9
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