PowerProtect: PPDM Filesystem backup fails with "Unsupported or unrecognized SSL message"

Summary: This article provides a solution to a problem where the Windows Windows Filesystem backup fails with "Unsupported or unrecognized SSL message."

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms

Filesystem backups fail with the following message "Unsupported or unrecognized SSL message."

/var/log/brs/adm/adm.log shows.
 
 to host <Windows_IP> with error Exception Details : javax.net.ssl.SSLException: Unsupported or unrecognized SSL message
Thrown from
com.emc.dpsg.ecdm.adm.schema.client.ApiClient.execute(ApiClient.java:721)
com.emc.dpsg.ecdm.adm.schema.client.agentservice.BackupApi.createBackupSessionWithHttpInfo(BackupApi.java:142)
com.emc.dpsg.ecdm.adm.server.service.plc.version.v2_2.AgentBackupRequestor$1.execute(AgentBackupRequestor.java:854)
java.base/sun.security.ssl.SSLSocketInputRecord.handleUnknownRecord(SSLSocketInputRecord.java:451)
java.base/sun.security.ssl.SSLSocketInputRecord.decode(SSLSocketInputRecord.java:175)

Cause

This problem may happen if there are changes that invalidate the PowerProtect Data Manager certificate on the Windows Computer.

Resolution

On the windows machine:
  1. Run unregister.bat as an administrator
  2. Rename C:\Program Files\DPSAPPS\AgentService\ssl to C:\Program Files\DPSAPPS\AgentService\ssl.old
  3. Rename C:\Program Files\DPSAPPS\AgentService\dbs\v1\resources.db to C:\Program Files\DPSAPPS\AgentService\dbs\v1\resources.db.old
  4. Run register.bat as administrator
  5. Approve the registration on PowerProtect Data Manager side. 
  6. Check that backups are now working.

Article Properties
Article Number: 000210904
Article Type: Solution
Last Modified: 24 May 2023
Version:  3
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