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Dell Unity: The EOL flag may be set on some SSD drives after being powered on for over 6.8 years-Dell Correctable

Summary: The EOL flag may be set on some SSD drives after they have been powered on for over 6.8 years.

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Article Content


Symptoms

The EOL flag may be set on some SSD drives after they have been powered on for over 6.8 years.

Cause

The drive vendor has confirmed that the drive SMART POH is a 4-byte counter. It counts the number of 50-millisecond clock ticks since manufacturing for which the drive is powered on. This counter wrapped due to the drive being powered on for ~59,652 hours, or ~6.8 years.

When the Power on Hours (POH) counter wraps, it resets to zero and starts to increment again. The wear level of the drive is unaffected. This results in the calculated days remaining to reach EOL for any drive with a wear level >25% to become ZERO. This results in the EOL flag to be set to TRUE for the drive.

The following TLAs are affected per analysis performed by Hardware Engineering.

  005051545 005051577 005051582 005051587 005051592 005052247 005052255 005053260
  005051547 005051578 005051583 005051588 005052236 005052248 005052256 005053261
  005051548 005051579 005051584 005051589 005052237 005052252 005052257 005053264
  005051549 005051580 005051585 005051590 005052239 005052253 005052258 005053267
005051543 005051550 005051581 005051586 005051591 005052246 005052254 005052259 005053731

 

Resolution

Fix:
This issue is addressed in the Unity operating system: 5.3.1.0.5.008

A hotfix for this issue is also available in the following code versions:

  • 5.3 Family: Unity OE 5.3.0.0.6.132
  • 5.2 Family: Unity OE 5.2.2.0.6.230

Contact Dell Technical Support or your Authorized Service Provider and quote this knowledge base article ID in order to obtain the fix.

Workaround:

NOTE: The drive itself is usable even after the EOL flag is set. If it is confirmed that the drive EOL flag was set due to this issue, there is no reason to replace the drive or clear the EOL flag.

If you believe that a drive in your system has encountered this issue, contact Dell Technical Support or your Authorized Service Provider to discuss the condition and next steps.

Article Properties


Affected Product

Unity All Flash, Dell EMC Unity Family |Dell EMC Unity All Flash, Dell EMC Unity Family, Dell EMC Unity Hybrid, Unity Hybrid flash

Last Published Date

31 Jan 2024

Version

11

Article Type

Solution