Data Domain: Cloudniveauenhed vises som "Slet-afventer" efter fjernelse
Oversigt: I denne artikel beskrives et problem, hvor fjernelse af Cloud Tier-enheden mislykkedes. Cloud Tier-enheden fjernes ikke, og systemet viser den som Slet-afventer.
Symptomer
DD Cloud Tier er en indbygget funktion i DD OS 6.0 (eller højere) til flytning af data fra det aktive niveau til billig objektstorage med høj kapacitet i den offentlige, private eller hybridsky til langsigtet opbevaring. Nedenstående problem kan opstå, når et Cloud-niveau slettes.
Nogle gange, hvis systemet ikke kan få adgang til enhedsskyen, vises det fjernede cloudniveau som "Slet-afventer", når kommandoen "#cloud enhedsliste" udstedes som vist nedenfor:
sysadmin@datadomainKB# cloud unit list Name Profile Status ------------- --------------------- -------------- RemovedUnitCl RemovedUnitCl_profile Delete-Pending NewUnitCl NewUnitClprofile Active ------------- --------------------- --------------
Dette problem kan ledsages af følgende advarsel, som snart ryddes:
EVT-CLOUD-00001 Unable to access provider for cloud unit <Cloud_unit_name>.
Årsag
Ovenstående scenarie kan opstå, hvis en kunde forsøger at slette til en ubrugt cloudenhed under en af følgende betingelser.
- Cloudtjenesteudbyder er ikke længere tilgængelig.
- Kunden har slettet S3 bucket/Blob Container, der bruges af Data Domain Cloud-enheden, direkte fra storageudbyderen eller tredjepartshjælpeprogrammer
- Objektstorage, der bruges i backend, er blevet taget ud af drift.
Løsning
Der er ingen indvirkning på Data Domain. Det er nødvendigt med nedetid for at løse dette problem, da filsystemet skal genstartes for at fjerne Cloud Unit-niveauet.
Kontakt DELL Support ved at oprette en ny supportanmodning eller chatte om hjælp.
- Kundens cloud storage-administrator tager ansvar for at slette data fra det respektive objektstorage.
- Hvis data ikke fjernes fra objektstorage, kan det resultere i løbende fakturering fra cloudlagerudbyderen