NetWorker-fejlfindingsvejledning: Procesnedbrud og kernedumps

Oversigt: Omfattende vejledning til fejlfinding af procesnedbrud og Core Dumps

Denne artikel gælder for Denne artikel gælder ikke for Denne artikel er ikke knyttet til et bestemt produkt. Det er ikke alle produktversioner, der er identificeret i denne artikel.

Symptomer

NetWorker-fejlfindingsvejledning: Procesnedbrud og kernedumps

Video: Omfattende vejledning til fejlfinding af procesnedbrud og Core Dumps

Se på YouTubeDette hyperlink fører dig til et websted uden for Dell Technologies.

Årsag

Der kan være mange forskellige årsager til, at en NetWorker-proces ikke svarer. Denne artikel beskriver den anbefalede metode til at isolere og løse et problem med NetWorker-processen, hvor der ikke svares.

Løsning

BEMÆRK: Før du foretager fejlfinding og diagnosticering af et kernedump på dit system, skal du søge på Dells supportwebsted efter artikler, der er specifikke for den proces, som kernen dumpede. I nogle scenarier er der en kendt rettelse bogført. Hvis der ikke identificeres nogen rettelser, skal du fortsætte med de trin, der er beskrevet i denne artikel. Hvert trin indeholder instruktioner eller et link til et dokument for at eliminere mulige årsager og foretage korrigerende handlinger efter behov. Trinnene er sorteret i den mest hensigtsmæssige rækkefølge for at isolere problemet og identificere den korrekte løsning. Spring ikke et trin over.

Trin 1: Indsamling af oplysninger - Problembeskrivelse:

For at generere en komplet problembeskrivelse skal du løse følgende spørgsmål:
  • Under hvilke omstændigheder går processen ned. Er denne adfærd konsekvent?
  • Fungerede dette bedre før?
  • Tidspunkter for forekomster og observeret adfærdstendens?
  • Opstår problemet kun i tider med stor belastning af sikkerhedskopieringsmiljøet eller sikkerhedskopier eller en bestemt type sikkerhedskopieringsgruppe?
  • Hvornår opstod problemet første gang? Hvad ændrede sig så?
  • Hvad er problemets omfang (alle klienter/nogle klienter, alle backupmål eller nogle)
  • Hvad der hidtil er forsøgt at rette, og hvilke konklusioner der er draget af dette.

Trin 2: Indsamling af oplysninger - Miljø

Hvilken NetWorker-proces der ikke svarer, og på hvilken maskine (server, storagenode eller klient).

Trin 3: Understøttelse

  • Ved hjælp af online NetWorker-kompatibilitetsvejledningen (kræver login til Dell Support-konto) skal du kontrollere, at alle komponenter (NetWorker-server, filsystemversion, proxy, storagenoder, klienter, mål) understøttes.
  • Kontroller, at der ikke er nogen underliggende operativsystem- eller hardwarefejl, der kan forklare procesnedbrud (diskfejl, disk fuld, netværksfejl osv.).

Trin 4: Bedste praksis

Planlægningsguiden til NetWorker Performance Optimization indeholder en liste over software- og hardwarekrav, der understøtter et optimalt indstillet NetWorker-miljø. Dette skal gennemgås for at sikre, at bedste praksis følges. Dette er relevant, hvis processen, der ikke reagerer, sker på tidspunkter med tungeste belastning. NetWorker-dokumentation er tilgængelig via: Support til NetWorker | Drivere og downloads 


Trin 5: Isolering af komponenter:

Hvordan vi finder årsagen til, at processen ikke reagerer, afhænger af adfærden som defineret i trin 1. Hvis udløseren er ukendt, kan der udføres test for at forsøge at fastslå, hvad der udløser nedbruddet:
 

  • Overvåg systemets ydeevne under kraftig belastning
  • Undersøg operativsystemets logfiler omkring tidspunktet for nedbruddene for at kontrollere, om de er ensartet i adfærden.
    • Linux: /var/log/messages
    • Windows: System- og applikationshændelseslogfiler
  • Gennemse NetWorker-logfiler for at se, hvilke handlinger der udføres, når de centrale dumps finder sted, og hvornår:
  • Find ud af, hvilke ikke-NetWorker-handlinger, der kører på denne maskine, som kan påvirke dens funktionsmåde, og om deres tidsplan korrelerer med tidspunkterne for nedbrud.
  • Hvis nedbruddet sker konsekvent, skal du ændre nogle parametre for at forsøge at indsnævre årsagen.  F.eks. sikkerhedskopiering til et andet destinationsmedie eller sikkerhedskopiering af forskellige typer data fra den samme NetWorker-klient


Trin 6: Opløsning

Et kernedump er en fil, der fanger en proces' arbejdshukommelse på et bestemt tidspunkt, normalt når programmet afsluttes unormalt. Et kernedump hjælper med at identificere, hvorfor en proces ikke reagerer, ved at afsløre de funktioner, der udføres, og de data, der er i brug på fejltidspunktet.

  1. Tjek /nsr/cores bibliotek for de seneste kernedumps af NetWorker-processer i UNIX eller Linux, eller kontroller nedbrudsmappen som defineret i Windows-registreringsdatabasen (se trin 2).
  2. Hvis der ikke er nogen, skal du kontrollere, at operativsystemet er konfigureret til at generere centrale dumpfiler, hvis der er et procesnedbrud. Se dokumentationen til operativsystemet for at få alle oplysninger, men kort fortalt indebærer dette ændringer ulimit -c og -f værdier i UNIX og Linux og foretage en ændring i registreringsdatabasen i Windows.
  3. Operativsystemværktøjer som f.eks. gdb (UNIX og Linux) og WinDbg (Windows) kan bruges til at vurdere kernedumpet. Se dokumentationen fra OS-leverandøren om disse funktioner.
  4. Du kan finde oplysninger om NetWorker-supportgennemgang under: NetWorker: Sådan bruges pkgcore til generering af kernedumpbundter

Flere oplysninger

Når du engagerer NetWorker-support i forbindelse med kernedumprelaterede sager, skal de oplysninger, der indsamles ved at følge denne artikel, angives. Et NSRGET-bundt og kernedumpet pkgcore Der skal også leveres bundter.

Berørte produkter

NetWorker

Produkter

NetWorker
Artikelegenskaber
Artikelnummer: 000034716
Artikeltype: Solution
Senest ændret: 23 jan. 2026
Version:  7
Find svar på dine spørgsmål fra andre Dell-brugere
Supportservices
Kontrollér, om din enhed er dækket af supportservices.