Data Protection Advisor: Avamar Collection-anmodninger mislykkes med "Kunne ikke oprette forbindelse til databaseserver"

Oversigt: Data Protection Advisor (DPA): Avamar Collection-anmodninger mislykkes med meddelelsen "Der kunne ikke oprettes forbindelse til databaseserveren".

Denne artikel gælder for Denne artikel gælder ikke for Denne artikel er ikke knyttet til et bestemt produkt. Det er ikke alle produktversioner, der er identificeret i denne artikel.

Symptomer

Avamar dataindsamlingsanmodninger mislykkes med meddelelsen:
 Failed to connect to database server
Fra Run in Debug dpaagent.log ser fejlen sådan ud:
DBG1     4640.1508     20170417:154119    sodbc.pgsql.sodbc - sodbcOpen(): Failed to connect to database server. server= Avamar_server.FQDN, dbname=mcdb, user=viewuser, port=5555. Error was: Connection to database mcdb failed: could not translate host name "Avamar_server.FQDN" to address: Unknown host
 (-1)
DBG1     4640.1508     20170417:154119    sodbc.pgsql.connect - cpgsql():  Closing connection to postgres database. Server= Avamar_server.FQDN, DB=mcdb, Port=5555, User=viewuser
ERR      4640.1508     20170417:154119    agent.mod.avamar - jobmonitor(): failed to connect to server
Agenten kan ikke oversætte Avamar-værtsnavnet Avamar_server.FQDN som er Avamar-serverobjektet i DPA-lageret.

Kørsel af nslookup fra agentværten ved hjælp af Avamar_server.FQDN eller Avamar-serverens IP-adresse mislykkes, men det korte navn fortolkes korrekt.

Årsag

DPA-produktet virker efter hensigten. Dette er et DNS-problem (Domain Name System).

Løsning

Ret DNS.
 
I et tilfælde blev problemet løst efter tilføjelse Avamar_server.FQDN og IP-adressen i værtsfilen på fjernagenten.
 
Kontakt Dells tekniske supportteam for at få flere oplysninger.

Berørte produkter

Data Protection Advisor
Artikelegenskaber
Artikelnummer: 000052149
Artikeltype: Solution
Senest ændret: 23 jun. 2026
Version:  6
Find svar på dine spørgsmål fra andre Dell-brugere
Supportservices
Kontrollér, om din enhed er dækket af supportservices.