CloudLink. Агент CloudLink не отвечает из-за утечки памяти.

Oversigt: Сбой CloudLink из-за утечки памяти, обнаруженной в 7.1.1 и 7.1.2. Клиенты KMIP не затрагиваются.

Denne artikel gælder for Denne artikel gælder ikke for Denne artikel er ikke knyttet til et bestemt produkt. Det er ikke alle produktversioner, der er identificeret i denne artikel.

Symptomer

Агент будет отключен от CLC из-за утечки памяти. Во время этого невозможно выполнять такие действия администратора, как добавление новых дисков, удаление дисков и замена ключей, так как агент отключен. Операции ввода-вывода не будут затронуты, так как диски уже имеют ключи.

Журналы ОС:
Linux.
После сбоя службы svmd в Linux запись в /var/log отображается в RHEL или CentOS с ошибкой нехватки памяти.image.png
Windows.
В случае Windows любой сбой будет зарегистрирован в журналах средства просмотра событий Windows. Служба может автоматически запускаться в Windows с настройками восстановления по умолчанию, поэтому агент попытается восстановить соединение с сервером CloudLink.
 
В пользовательском веб-интерфейсе CloudLink Center агент показывает сообщение об отключении после сбоя службы:
image.png

Журналы нескольких сеансов показывают, что сеанс агента закрылся после сбоя службы:
image.png

Årsag

Для обеспечения комплаенса в области безопасности средство CloudLink модернизировало библиотеку TLS стороннего производителя, используемую в агенте, до последней версии. Новая версия библиотеки изменила процесс обмена сообщениями, что приводит к выделению памяти в коде агента в цикле.

Løsning

Решение.
Для повторного запуска службы требуется перезапустить службу агента CloudLink.
  • В Linux: После сбоя службу агента можно перезапустить вручную. Потеря данных отсутствует, так как зашифрованный диск остается зашифрованным. Команда для перезапуска службы агента: service svmd restart.
  • В Windows: После сбоя Windows автоматически перезапустит службу, если настройки восстановления службы установлены на перезапуск службы (по умолчанию). Потеря данных отсутствует, так как зашифрованный диск остается зашифрованным.

Окончательное решение.
Эта проблема устранена в CloudLink 7.1.3.

Flere oplysninger

ОС Linux.
Например, в системе с 2 Гбайт памяти сбой службы агента происходил через 5 дней, когда потребление памяти увеличивалось примерно до 1,6 Гбайт, при этом средняя утечка составляла 300 Мбайт в день.

ОС Windows.
Например, в системе с 4 Гбайт памяти потребление памяти службой агента увеличивается и достигает 1,9 Гбайт. Предполагается, что сбой происходит, когда потребление достигает примерно 3 Гбайт при средней утечке 400 Мбайт в день.

Berørte produkter

CloudLink SecureVM, CloudLink
Artikelegenskaber
Artikelnummer: 000197219
Artikeltype: Solution
Senest ændret: 13 maj 2026
Version:  4
Find svar på dine spørgsmål fra andre Dell-brugere
Supportservices
Kontrollér, om din enhed er dækket af supportservices.