Dell VNX: Unable to connect to Unisphere GUI after Java update (User Correctable)

Oversigt: After updating Java to latest version, Unisphere may stop connecting properly.

Denne artikel gælder for Denne artikel gælder ikke for Denne artikel er ikke knyttet til et bestemt produkt. Det er ikke alle produktversioner, der er identificeret i denne artikel.

Symptomer

Java starts up but the Unisphere login window is never shown.

Årsag

Oracle changed Java to disable TLSv1 and TLSv1.1 by default. Both algorithms are still required by VNX Unisphere to properly open its GUI. This issue has first been observed on Java version 1.8.0_291, but it may also occur with other versions. 

Løsning

Steps to re-enable TLSv1 and TLSv1.1:

1. Go to the Java path "lib\security" folder (eg. "C:\Program Files (x86)\Java\jre1.8.0_291\lib\security").

2. Open file java.security with admin rights.

3. Search for this parameter jdk.tls.disabledAlgorithms

4. Edit line to remove TLSv1 and TLSv1.1

    Before
    jdk.tls.disabledAlgorithms=SSLv3, TLSv1, TLSv1.1, RC4, DES, MD5withRSA

    After
    jdk.tls.disabledAlgorithms=SSLv3, RC4, DES, MD5withRSA

5. Save file.

6. Clear browser's cache and cookies.

7. Relaunch browser and try opening Unisphere again. It should work fine.

Berørte produkter

VNX/VNXe, VNX1 Series, VNX2 Series

Produkter

VNX5100, VNX5200, VNX5300, VNX5400, VNX5500, VNX5600, VNX5700, VNX5800, VNX7500, VNX7600, VNX8000
Artikelegenskaber
Artikelnummer: 000202925
Artikeltype: Solution
Senest ændret: 05 jan. 2023
Version:  2
Find svar på dine spørgsmål fra andre Dell-brugere
Supportservices
Kontrollér, om din enhed er dækket af supportservices.