Avamar – Slabý výkon zálohování u klienta Avamar se spuštěným antivirovým programem Sophos

Zusammenfassung: Tento článek pojednává o situacích, kdy u klienta Avamar s antivirovým programem Sophos dochází ke špatnému výkonu zálohování.

Dieser Artikel gilt für Dieser Artikel gilt nicht für Dieser Artikel ist nicht an ein bestimmtes Produkt gebunden. In diesem Artikel werden nicht alle Produktversionen aufgeführt.

Symptome

Toto chování může způsobit dlouhodobé zálohování Softwaru Avamar a může zabránit dokončení zálohování v dostupném okně zálohování.

U klienta Avamar, kde je nainstalován antivirový software Sophos, může občas při spuštění kontroly na vyžádání společnosti Sophos docházet ke špatnému výkonu zálohování.

V dnech, kdy antivirový program Sophos provádí kontrolu na vyžádání, může společnost Avamar hlásit podíl změněných souborů za vysoké.  
 
avtar Info <5156>: Backup #82 timestamp 2014-03-21 16:24:53, 80,687 files, 11,757 folders, 46.06 GB (80,188 files, 17.03 GB, 36.98% new) avtar Info <6083>: Backed-up 46.06 GB in 73.38 minutes: 38 GB/hour (65,976 files/hour)
Avtar hlásí, že změněná data (hodnoty v závorkách) jsou v porovnání se zálohovanou datovou sadou velmi vysoká.  V takovém případě bylo zjištěno, že se změnilo více než 99 % souborů (80 188 souborů z 80 687).

V ostatních dnech je podíl změněných souborů obvyklejší.
avtar Info <5156>: Backup #91 timestamp 2014-04-03 10:11:54, 139,164 files, 13,805 folders, 60.73 GB (4 files, 280.1 KB, 0.00% new) avtar Info <6083>: Backed-up 60.73 GB in 7.03 minutes: 519 GB/hour (1,188,522 files/hour)

Ursache

Proces klienta Avamar (avtar) závisí na času ctime souboru, aby zjistil, zda byl tento soubor změněn. Pokud software třetí strany změní čas ctime souboru v datové sadě, společnost Avtar tento soubor zjistí, který se změnil. Společnost Avtar poté musí zpracovat (blok, komprimovat, hash) celý soubor.  

To může trvat dlouho, pokud došlo k úpravě času ctime u mnoha souborů nebo v případech, kdy jsou jednotlivé soubory velké.

Jak je popsáno v dokumentaci

Sophos 7.4 Archiver, zálohuje všechny soubory, které byly na vyžádání prohledány.
 
 Důvodem jsou změny, které antivirová ochrana Sophos provádí v době změny stavu souborů. Ve výchozím nastavení se antivirová ochrana Sophos pokusí obnovit čas přístupu (atime) souborů na čas zobrazený před kontrolou.
Tím se však změní čas změny stavu struktury inode (ctime). Pokud archivátor použije čas CTIME k rozhodnutí, zda došlo ke změně souboru, zazálohuje všechny soubory skenované společností Sophos Anti-Virus.
 
Vyřešte problém:

Proveďte příkaz "sweep" s možností--no-reset-atime.


Lösung

Postupujte podle dokumentace společnosti Sophos a nakonfigurujte sophos, aby spouštěl příkaz --no-reset-atime.

Betroffene Produkte

Avamar

Produkte

Avamar, Avamar Client
Artikeleigenschaften
Artikelnummer: 000041039
Artikeltyp: Solution
Zuletzt geändert: 06 Feb. 2025
Version:  5
Antworten auf Ihre Fragen erhalten Sie von anderen Dell NutzerInnen
Support Services
Prüfen Sie, ob Ihr Gerät durch Support Services abgedeckt ist.