ViPR SRM: Ett fel uppstod när mysql-database-check.sh kördes
Zusammenfassung: mysql-database-check-sh visar att åtgärden misslyckades
Dieser Artikel gilt für
Dieser Artikel gilt nicht für
Dieser Artikel ist nicht an ein bestimmtes Produkt gebunden.
In diesem Artikel werden nicht alle Produktversionen aufgeführt.
Symptome
Ett fel visas efter att mysql-database-check.sh
har körts:
har körts:
Error : Table apg.recovery_group doesn't exist Status : Operation failed
Ursache
Tabellen apg.recovery_group används under databaskontrollen för återställning, det är inte en nödvändig tabell och skapades inte under uppgiften just nu.
Lösung
Kör mysql-database-check-sh igen. Felet försvinner eftersom tabellen skapas igen på rätt sätt under uppgiften
Weitere Informationen
Så här kör du databaskontroll:
Logga in på varje backend-värd och kör följande kommando:
Alternativt kan vi utföra kontrollerna genom att följa stegen nedan:
Logga in på primär serverdel:
Gå in i databasen: [apg]
Ange lösenord: watch4net
På sekundära serverdelar loggar du in som root och utför på var och en av databaserna där en i taget, till exempel apg1, apg2, apg3 och apg4:
Gå in i databasen: [APG1]
Ange lösenord: watch4net
Logga in på varje backend-värd och kör följande kommando:
printf "apg\n--password=watch4net --all-databases\n" | /opt/APG/bin/mysql-database-check.sh
Alternativt kan vi utföra kontrollerna genom att följa stegen nedan:
Logga in på primär serverdel:
srm:/opt/APG/bin # ./mysql-database-check.shAnge användarnamn: [apg]
Gå in i databasen: [apg]
Ange lösenord: watch4net
På sekundära serverdelar loggar du in som root och utför på var och en av databaserna där en i taget, till exempel apg1, apg2, apg3 och apg4:
srm:/opt/APG/bin # ./mysql-database-check.shAnge användarnamn: [apg]
Gå in i databasen: [APG1]
Ange lösenord: watch4net
Betroffene Produkte
SRMArtikeleigenschaften
Artikelnummer: 000167710
Artikeltyp: Solution
Zuletzt geändert: 20 Juni 2024
Version: 5
Antworten auf Ihre Fragen erhalten Sie von anderen Dell NutzerInnen
Support Services
Prüfen Sie, ob Ihr Gerät durch Support Services abgedeckt ist.