ViPR SRM: Der opstod en fejl under kørsel af mysql-database-check.sh
Zusammenfassung: mysql-database-check-sh viser, at handlingen mislykkedes
Dieser Artikel gilt für
Dieser Artikel gilt nicht für
Dieser Artikel ist nicht an ein bestimmtes Produkt gebunden.
In diesem Artikel werden nicht alle Produktversionen aufgeführt.
Symptome
Der opstod en fejl efter kørsel mysql-database-check.sh
Fejl set:
Fejl set:
Error : Table apg.recovery_group doesn't exist Status : Operation failed
Ursache
Tabellen apg.recovery_group bruges under databasekontrollen for gendannelse, det er ikke en nødvendig tabel og blev ikke oprettet under opgaven på dette tidspunkt.
Lösung
Kør mysql-database-check-sh igen. Fejlen forsvinder, da tabellen oprettes korrekt igen under opgaven
Weitere Informationen
Sådan køres databasekontrol:
Log på hver Backend-vært, og kør følgende kommando:
Alternativt kan vi udføre kontrollerne ved at følge nedenstående trin:
Log ind på Primary BackEnd:
Indtast database: [APG]
Indtast adgangskode: watch4net
På sekundære backends skal du logge ind som root og udføre på hver af databaserne der en ad gangen, såsom apg1, apg2, apg3 og apg4:
Indtast database: [APG1]
Indtast adgangskode: watch4net
Log på hver Backend-vært, og kør følgende kommando:
printf "apg\n--password=watch4net --all-databases\n" | /opt/APG/bin/mysql-database-check.sh
Alternativt kan vi udføre kontrollerne ved at følge nedenstående trin:
Log ind på Primary BackEnd:
srm:/opt/APG/bin # ./mysql-database-check.shIndtast brugernavn: [APG]
Indtast database: [APG]
Indtast adgangskode: watch4net
På sekundære backends skal du logge ind som root og udføre på hver af databaserne der en ad gangen, såsom apg1, apg2, apg3 og apg4:
srm:/opt/APG/bin # ./mysql-database-check.shIndtast brugernavn: [APG]
Indtast database: [APG1]
Indtast adgangskode: watch4net
Betroffene Produkte
SRMArtikeleigenschaften
Artikelnummer: 000167710
Artikeltyp: Solution
Zuletzt geändert: 20 Juni 2024
Version: 5
Antworten auf Ihre Fragen erhalten Sie von anderen Dell NutzerInnen
Support Services
Prüfen Sie, ob Ihr Gerät durch Support Services abgedeckt ist.