CloudLink: Poista käytöstä AWS-konsolin yhteys CloudLink-käyttöjärjestelmään
Zusammenfassung: AWS:llä on esiasennettu SSM-agentti kaikissa tuetuissa käyttöjärjestelmissä. Tämä SSM-agentti antaa myös pääsyn suoraan CloudLink-käyttöjärjestelmän konsoliin.
Dieser Artikel gilt für
Dieser Artikel gilt nicht für
Dieser Artikel ist nicht an ein bestimmtes Produkt gebunden.
In diesem Artikel werden nicht alle Produktversionen aufgeführt.
Symptome
Dell suosittelee, että SSM-agentti poistetaan CloudLink-esiintymistä, koska se aiheuttaa tietoturvahaavoittuvuuksia.
Ursache
AWS:ssä SSM-agentti on esiasennettuna kaikissa tuetuissa käyttöjärjestelmissä, jotta käyttöjärjestelmäkonsoli voidaan avata suoraan.
Tuotteet ja versiot, joita ongelma koskee: Kaikki CloudLink-versiot versioon 7.1.3 saakka, kun ne otetaan käyttöön AWS:ssä.
Tuotteet ja versiot, joita ongelma koskee: Kaikki CloudLink-versiot versioon 7.1.3 saakka, kun ne otetaan käyttöön AWS:ssä.
Lösung
Jotta kirjautuminen voidaan poistaa käytöstä Session Managerin kautta CloudLink-käyttöjärjestelmään, järjestelmänvalvojan on poistettava SSM-agentti CloudLink-esiintymästä.
Kiertotapoja on kaksi:
Remediation workflow 1: Kun käyttäjä voi käyttää CloudLink-konsolia Session Managerin kautta,
Korjaustyönkulku 2: Kun käyttäjä ei voi käyttää CloudLink-konsolia Session Managerin kautta,
Korjaustyönkulku 1:
1. CloudLink-esiintymä.
2. Valitse Session Manager -välilehdessä -> Connect (Yhdistä) -painike
3. Kun olet CloudLink-konsolissa Session Managerilla, kirjoita sudo su
4. Tarkista CloudLink-konsolissa käynnissä olevan SSM-agentin tila komennolla
systemctl status snap.amazon-ssm-agent.amazon-ssm-agent.service"
5. Voit näyttää käynnissä olevan SSM-agentin CloudLink-konsolissa komennolla
snap list amazon-ssm-agent"
6. Poista SSM-agentti CloudLink-konsolista komennolla
snap remove amazon-ssm-agent Validate
SSM agent is removed from CloudLink instance.
7. Kun SSM-agentin CloudLink-esiintymän asennus poistetaan, Connect-painike poistetaan käytöstä
8. Kun käyttäjä yrittää SSH:n ja CloudLinkin IP-osoitetta, käyttäjä siirtyy CloudLink-kirjautumiskehotteeseen
9. Tarkista SSM-agentin tila. Varmista, että agentti on "Pysähtynyt"
10. Tarkista SSM-agenttien luettelo. Tilailmoitus No matching snaps installed.
Korjaustyönkulku 2:
Session Manager ei ole käytössä, kun IAM-roolia ei ole valittu. Ilman Istunnon hallintaa käyttäjä ei voi käyttää CloudLink-konsolia.
Voit tarkistaa IAM-profiilin kirjautumalla AWS-> Launch EC2 -instance -> Advanced details -> IAM Instance profile
Recommended not select any profile under "IAM Instance profile", mikä estää Session Manageria muodostamasta yhteyttä CloudLink-konsoliin.
HUOMAUTUS: Jos Session Manager ei voi muodostaa yhteyttä CloudLink-konsoliin, käyttäjän on otettava yhteys tekniseen tukeen , jotta SSM-agentin asennus voidaan poistaa CloudLink-esiintymistä.
Kiertotapoja on kaksi:
Remediation workflow 1: Kun käyttäjä voi käyttää CloudLink-konsolia Session Managerin kautta,
Korjaustyönkulku 2: Kun käyttäjä ei voi käyttää CloudLink-konsolia Session Managerin kautta,
Korjaustyönkulku 1:
1. CloudLink-esiintymä.
2. Valitse Session Manager -välilehdessä -> Connect (Yhdistä) -painike
3. Kun olet CloudLink-konsolissa Session Managerilla, kirjoita sudo su
4. Tarkista CloudLink-konsolissa käynnissä olevan SSM-agentin tila komennolla
systemctl status snap.amazon-ssm-agent.amazon-ssm-agent.service"
5. Voit näyttää käynnissä olevan SSM-agentin CloudLink-konsolissa komennolla
snap list amazon-ssm-agent"
6. Poista SSM-agentti CloudLink-konsolista komennolla
snap remove amazon-ssm-agent Validate
SSM agent is removed from CloudLink instance.
7. Kun SSM-agentin CloudLink-esiintymän asennus poistetaan, Connect-painike poistetaan käytöstä
8. Kun käyttäjä yrittää SSH:n ja CloudLinkin IP-osoitetta, käyttäjä siirtyy CloudLink-kirjautumiskehotteeseen
9. Tarkista SSM-agentin tila. Varmista, että agentti on "Pysähtynyt"
10. Tarkista SSM-agenttien luettelo. Tilailmoitus No matching snaps installed.
Korjaustyönkulku 2:
Session Manager ei ole käytössä, kun IAM-roolia ei ole valittu. Ilman Istunnon hallintaa käyttäjä ei voi käyttää CloudLink-konsolia.
Voit tarkistaa IAM-profiilin kirjautumalla AWS-> Launch EC2 -instance -> Advanced details -> IAM Instance profile
Recommended not select any profile under "IAM Instance profile", mikä estää Session Manageria muodostamasta yhteyttä CloudLink-konsoliin.
HUOMAUTUS: Jos Session Manager ei voi muodostaa yhteyttä CloudLink-konsoliin, käyttäjän on otettava yhteys tekniseen tukeen , jotta SSM-agentin asennus voidaan poistaa CloudLink-esiintymistä.
Betroffene Produkte
CloudLink SecureVM, CloudLinkArtikeleigenschaften
Artikelnummer: 000200819
Artikeltyp: Solution
Zuletzt geändert: 14 Mai 2026
Version: 6
Antworten auf Ihre Fragen erhalten Sie von anderen Dell NutzerInnen
Support Services
Prüfen Sie, ob Ihr Gerät durch Support Services abgedeckt ist.