NVP vProxy: Proces wskrzeszania zestawu zapisu maszyny wirtualnej nie postępuje

Zusammenfassung: Zestaw zapisu maszyny wirtualnej, który znajduje się na urządzeniu innym niż DDboost (AFTD, taśma, CloudBoost), jest wskrzeszany (klonowany) z powrotem na urządzeniu Data Domain w celu przywrócenia. Proces wskrzeszania nie postępuje i żadne dane nie są klonowane na postojowe urządzenie dd. ...

Dieser Artikel gilt für Dieser Artikel gilt nicht für Dieser Artikel ist nicht an ein bestimmtes Produkt gebunden. In diesem Artikel werden nicht alle Produktversionen aufgeführt.

Symptome

Przywrócenie wskrzeszenia maszyny wirtualnej (VM) zostało zainicjowane z poziomu konsoli NetWorker Management Console (NMC) lub sieciowego interfejsu użytkownika NetWorker (NWUI).

UWAGA: Przywracanie po wskrzeszeniu jest procesem automatycznym, który występuje, gdy zestaw zapisu wybrany do przywrócenia znajduje się na urządzeniu innym niż Data Domain (AFTD, Tape, CloudBoost). Po wybraniu źródłowego zestawu zapisu dostępna jest opcja wyboru puli "przejściowej", w której skonfigurowane jest urządzenie klonujące Data Domain. Proces wskrzeszania klonuje zestaw zapisu z powrotem do puli przejściowej DD, a następnie inicjuje przywracanie.

Proces wskrzeszania się rozpoczął, ale nie widać transferu danych:

Sesja odzyskiwania

W oknie Alerty NMC wyświetlany jest komunikat "oczekiwanie na wolumin zapisywalny" w wybranej puli przejściowej. 

Alerty NMC

Pula przejściowa ma zamontowane urządzenie:

image.png

Ursache

Kopia tego samego zestawu zapisu znajduje się już na woluminie urządzenia przejściowego.

1. Potwierdź identyfikator SSID z sesji odzyskiwania:

Sesja odzyskiwania

3. Użyj polecenia mminfo, aby sprawdzić, czy zestaw zapisu pojawia się na urządzeniu przejściowym:
 

mminfo -kot -q ssid=SSID

Example:

nve:~ # mminfo -kot -q ssid=2891939064
 volume        type   vm_name         date     time         size ssid      fl backup_size
AFTDVMClone.001 adv_file lnx-client01  06/04/24 16:45:43  104 GB 2891939064 cr 104 GB
ddvestaging.001 Data Domain lnx-client01 06/04/24 16:45:43 104 GB 2891939064 cr 104 GB

Jest to zamierzone. Nie można utworzyć wielu kopii tego samego zestawu zapisu w tej samej lokalizacji docelowej. W Podręczniku integracji NetWorker VMware czytamy: Upewnij się, że wybrana pula nie zawiera już kopii tej kopii zapasowej. Jeśli podstawowe źródło jest obecne i wybierzesz klon do odzyskania przy użyciu tej samej puli przejściowej, która zawiera istniejącą kopię, odzyskiwanie może przestać odpowiadać.

Lösung

Sprawdź flagę zapisu zestawu kopii na woluminie przejściowym:

nve:~ # mminfo -kot -q volume=ddvestaging.001
 volume        type   vm_name         date     time         size ssid      fl backup_size
ddvestaging.001 Data Domain lnx-client01 06/04/24 16:45:43 104 GB 2891939064 cr 104 GB

W niektórych przypadkach poprzednie wskrzeszenie mogło zostać zakończone, ale błąd nsrclone mógł spowodować, że zestaw zapisu został oznaczony jako przerwany (ca) lub podejrzany (s). Spowodowałoby to niepowodzenie przywracania, a zestaw zapisów nie kwalifikowałby się do przywrócenia. Istnieją dwie opcje w zależności od tego, czy kopia jest prawidłowa.

Prawidłowy zestaw zapisu na urządzeniu przejściowym.

1. Na karcie Odzyskaj kliknij prawym przyciskiem myszy sesję odzyskiwania i kliknij przycisk Zatrzymaj.
2. Uruchom ponownie odzyskiwanie i wybierz zestaw zapisu, który został sklonowany z powrotem do DD. Kopia powinna zawierać się w kolumnach "Data Domain Copies" i "Other Media Copies":

Dostępne zestawy zapisów

3. Na stronie Select Alternate Recovery Sources wybierz kopię z urządzenia klonującego Data Domain:
Urządzenie do klonowania Data Domain

4. Wykonaj przywracanie.

Zestaw zapisów jest nieprawidłowy

Jeśli zestaw zapisu jest nieprawidłowy; Przerwane (CA) lub podejrzane (S). Musisz usunąć zestaw zapisów i ponownie uruchomić zmartwychwstanie.

1. Uzyskaj identyfikator SSID i identyfikator klona zestawu zapisu, który znajduje się na urządzeniu przejściowym.
mminfo -kot -q volume=VOLUME_NAME -r vmname,savetime,sumflags,ssid,cloneid
Example:
nve:~ # mminfo -kot -q volume=ddvestaging.001 -r vmname,savetime,sumflags,ssid,cloneid
 vm_name    date   fl ssid          clone id
lnx-client01 06/04/24 ca 2891939064 1718033764
 
2. Używając zarówno identyfikatora ssid/cloneid. Usuń zestaw zapisów:
nsrmm -d -S SSID/CLONEID
Example:
nve:~ # nsrmm -d -S 2891939064/1718033764

The following clones will be deleted:
2891939064/1718033764

Continue? y
Processing the clone list.
Deleting clones.
PRZESTROGA: Ważne jest, aby określić zarówno identyfikator SSID, jak i CLONEID. Jeśli określisz tylko identyfikator SSID, program może usunąć wszystkie kopie tego zestawu zapisu z modułu MM, w tym dane źródłowe.

3. Uruchom ponownie przywracanie po wskrzesieniu, wybierając zestaw zapisu zawierający tylko opcję "Other Media Copy". Wybierz pulę przejściową i rozpocznij przywracanie. Zestaw zapisów zostanie sklonowany do puli przejściowej, a proces przywracania rozpocznie się po zakończeniu klonowania.

Weitere Informationen

W przypadku zaobserwowania problemu polegającego na tym, że klon nie jest ukończony lub kończy się, ale wydaje się nieprawidłowy. Usuń nieprawidłowy przerwany (ca) lub podejrzany(e) zestaw zapisu zgodnie z powyższym opisem. Ręcznie sklonuj zestaw zapisu za pomocą polecenia nsrclone i sprawdź dane wyjściowe nsrclone, aby uzyskać więcej informacji:
nsrclone -vvv [{optional} -D[1-7]] -b STAGING_POOL_NAME -S SSID/CLONEID

Gdzie SSID/CLONEID jest identyfikatorem SSID i CloneId zestawu zapisu znajdującego się na urządzeniu innym niż DD. Dane wyjściowe mogą być przekierowane do pliku; opcjonalnie można dodać debugowanie z -D poziomami od 1 do 7. 

Patrz: NVP vProxy: Jak ręcznie sklonować zestaw zapisu maszyny wirtualnej z urządzenia innego niż Data Domain do urządzenia klonującego Data Domain?

Może być wymagana analiza zrzutu sfs i dziennika ddfs.info docelowego Data Domain.

Betroffene Produkte

NetWorker

Produkte

NetWorker Family, NetWorker Series
Artikeleigenschaften
Artikelnummer: 000225923
Artikeltyp: Solution
Zuletzt geändert: 22 Mai 2025
Version:  2
Antworten auf Ihre Fragen erhalten Sie von anderen Dell NutzerInnen
Support Services
Prüfen Sie, ob Ihr Gerät durch Support Services abgedeckt ist.