PowerMax 2500 e 8500: O host não consegue detectar o PowerMax usando NVMe/TCP

Zusammenfassung: O host não consegue detectar e se conectar ao PowerMax quando um endpoint NVMe/TCP (IPPT) no PowerMax é configurado no modo Advertise Direct Discovery Controller (DDC).

Dieser Artikel gilt für Dieser Artikel gilt nicht für Dieser Artikel ist nicht an ein bestimmtes Produkt gebunden. In diesem Artikel werden nicht alle Produktversionen aufgeführt.

Symptome

Níveis do PoweMaxOS afetados: 
  • 10.0.0.0 (Juniper)
  • 10.0.1.0 (Juniper-SR1)
  • 10.0.1.x (Juniper-SR1-hotfix)
Isso afeta os hosts que usam nvme-stas ou uma ferramenta semelhante que usa mDNS para detectar e se conectar ao PowerMax.


O seguinte comando no host Linux pode encontrar os serviços anunciados:

 
avahi-browse -t -v _nvme-disc._tcp
 
image.png

Use o seguinte comando para resolver a falha do domínio (opção -r).
avahi-browse -t -r -v _nvme-disc._tcp
 
image.png

Ursache

O problema é o registro de serviço (SRV) do servidor de nome de domínio (DNS) (https://en.wikipedia.org/wiki/SRV_record).
Os registros SRV têm um campo chamado "destino", o destino é o nome de host da entidade que fornece o serviço. O host pode usar esse hostname para recuperar o endereço IP. No PowerMax, esse mecanismo não funcionou porque o "destino" apontava para o nome de host errado, conforme mostrado na resposta de consulta a seguir.

image.png
 

Além do problema acima, o registro de recursos RR_TXT estava vazio na resposta à consulta causada por um problema de formatação ao criar a resposta de consulta.

Lösung

O problema é resolvido com a seguinte correção em Juniper-SR1-Hotfix:
10.0.1.x (Juniper-SR1-hotfix) - PMOS-59142

Solução temporária:
configure manualmente o endereço IP do DDC, o endereço IP associado ao IPPT no host.

Betroffene Produkte

PowerMax 2500, PowerMax 8500
Artikeleigenschaften
Artikelnummer: 000217103
Artikeltyp: Solution
Zuletzt geändert: 18 Mai 2026
Version:  7
Antworten auf Ihre Fragen erhalten Sie von anderen Dell NutzerInnen
Support Services
Prüfen Sie, ob Ihr Gerät durch Support Services abgedeckt ist.