Openshift-Ereigniscode: 1030NODE0004

Zusammenfassung: Das Dateisystem hat weniger als 3 % Inodes übrig.

Dieser Artikel gilt für Dieser Artikel gilt nicht für Dieser Artikel ist nicht an ein bestimmtes Produkt gebunden. In diesem Artikel werden nicht alle Produktversionen aufgeführt.

Symptome

Wenn das Dateisystem eines Node voll wird, hat dies weitreichende Auswirkungen. Dieses Problem kann dazu führen, dass bei einigen oder allen Anwendungen, die auf diesem Node geplant sind, eine herabgesetzte Leistung bis hin zur vollständigen Nichtverfügbarkeit auftreten kann.

Je nach beteiligtem Node und Dateisystem kann dieses Problem eine kritische Bedrohung für die Stabilität des Clusters darstellen.

Ursache

Die NodeFilesystemAlmostOutOfFiles-Warnmeldung ähnelt der NodeFilesystemSpaceFillingUp-Warnmeldung, basiert jedoch nicht auf der Vorhersage, dass einem Dateisystem in einer bestimmten Zeit die Inodes ausgehen werden, sondern verwendet einfache statische Schwellenwerte. Die Warnmeldung wird auf einer Warnstufe ausgelöst, wenn 5 % der verfügbaren Inodes verbleiben, und auf einer kritischen Stufe, wenn 3 % der verfügbaren Inodes verbleiben.

Lösung

Diagnose:
Notieren Sie sich die Bezeichnungen für Instanz und Einhängepunkt aus der Warnmeldung. Sie können den Nutzungsverlauf dieses Dateisystems grafisch darstellen, indem Sie die folgende Abfrage in der OpenShift-Webkonsole verwenden (beachten Sie → Metriken → Ausführen von Abfragen):
image.png

Sie können auch eine Debug-Sitzung auf dem Node öffnen und Linux-Standarddienstprogramme verwenden, um die Quelle der Nutzung zu finden:
image.png

Beachten Sie, dass in vielen Fällen für ein Dateisystem, dem die Inodes ausgehen, noch Speicherplatz verfügbar ist. Mangelnde Inodes werden häufig dadurch verursacht, dass eine Anwendung viele kleine Dateien erstellt.

Minderung: Die Anzahl der Inodes, die einem Dateisystem zugewiesen sind,
basiert in der Regel auf der Speichergröße. Möglicherweise können Sie das Problem lösen oder zumindest die negativen Auswirkungen des Problems hinauszögern, indem Sie die Größe des Speicher-Volumes erhöhen. Andernfalls bestimmen Sie die Anwendung, die eine große Anzahl kleiner Dateien erstellt, und passen Sie dann entweder ihre Konfiguration an oder stellen Sie ihr dedizierten Speicher zur Verfügung.

Support:
Wenn das Problem durch die oben genannten Schritte nicht behoben werden kann, wenden Sie sich für weitere Untersuchungen an den technischen Support von Dell EMC.

Betroffene Produkte

APEX Cloud Platform for Red Hat OpenShift
Artikeleigenschaften
Artikelnummer: 000217406
Artikeltyp: Solution
Zuletzt geändert: 13 Feb. 2026
Version:  3
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