ECS: Dial Home: EKMServerConnectionStatus, código del síntoma: 1369 y 1370

Summary: Se trata de un Call Home que se introdujo para detectar la alerta EKMServerConnectionStatus.

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Symptoms

ECS se comunicó con la siguiente alerta:
Código del síntoma Gravedad
1369 ADVERTENCIA
1370 ERROR
<?xml version="1.0" encoding="UTF-8"?>
<ConnectHome SchemaVersion="1.0.8"
    xsi:schemaLocation="/opt/connectemc/schema/ema_ConnectHome108.xsd" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance">
    <TransType>10</TransType>
    <TransTypeDesc>EventXML</TransTypeDesc>
    <TransID>0</TransID>
    <Node Status="Unknown" State="Unknown" ID="ECSQE00079">
        <Identifier>
            <DeviceState>1</DeviceState>
            <DeviceStatus>1</DeviceStatus>
            <ClarifyID>ECSQE00079</ClarifyID>
            <SiteName>UNKNOWN</SiteName>
            <Vendor>EMC</Vendor>
            <DeviceType>ElasticCloudStorageApp</DeviceType>
            <Model>ElasticCloudStorage</Model>
            <SerialNumber>ECSQE00079</SerialNumber>
            <WWN>ECSQE00079</WWN>
            <Platform>platform</Platform>
            <OS>SLES</OS>
            <OS_VER>12.3</OS_VER>
            <UcodeVer>3.3.0.0-4349.d0de882</UcodeVer>
            <EmbedLevel>2</EmbedLevel>
            <InternalMaxSize>512800</InternalMaxSize>
            <Comment>Object Alert</Comment>
        </Identifier>
        <Connection>
            <ConnectType>ESRS</ConnectType>
            <IPName>xxxxx-yyyyyy.ecs.lab.fqdn.com</IPName>
            <ConnectNum>xx.xxx.xxx.xx</ConnectNum>
            <Port>22</Port>
        </Connection>
        <HeartBeat>
            <HBStatus></HBStatus>
            <HBState></HBState>
        </HeartBeat>
        <InternalData>
            <FileList/>
            <EventList>
                <Event>
                    <SymptomCode>1370</SymptomCode>
                    <Category>Configuration</Category>
                    <Severity>Error</Severity>
                    <Status>Unknown</Status>
                    <Component>Object</Component>
                    <ComponentID></ComponentID>
                    <SubComponent>EKM Server Connection Status</SubComponent>
                    <SubComponentID></SubComponentID>
                    <CallHome>true</CallHome>
                    <FirstTime>2022-01-29T07:32:09.718Z</FirstTime>
                    <LastTime>2022-01-29T07:32:09.718Z</LastTime>
                    <Count>0</Count>
                    <EventData><![CDATA[]]></EventData>
                    <Description><![CDATA[The EKM Server: ecs-test-keysecure-xx.xxx.xxx.xxx is not responding. Please ensure that the server is connected.  [Ref_ID : EKMServerConnectionStatus]]]></Description>
                </Event>
            </EventList>
        </InternalData>
        <ExternalFiles/>
    </Node>
</ConnectHome>

Cause

El servidor de administración extensible de claves (EKM) no responde. Asegúrese de que el servidor esté conectado.

Resolution

Verificar el estado

Comando: 
svc_rest_cmd -i `hostname -i` /vdc/sensor/status/EKMServerConnectionStatus
Ejemplo:
# svc_rest_cmd -i `hostname -i` /vdc/sensor/status/EKMServerConnectionStatus
svc_rest_cmd 1.0.10

<?xml version="1.0" encoding="UTF-8" standalone="yes"?>
<SensorStatusList>
  <SensorId>KMServerConnectionStatus</SensorId>
  <ListSensorStatus>
    <SensorStatusRestRep>
      <ContextId>EKMServerConnectionStatus</ContextId>
      <CurrentState>OK</CurrentState>
      <NodeId>1f4368c3-37cd-467f-9efc-289264806ea0</NodeId>
      <PreviousState>OK</PreviousState>
      <Time>1551118064264</Time>
    </SensorStatusRestRep>
  </ListSensorStatus>
Busque CurrentState como se indicó anteriormente. Si se establece en OK, el error se puede ignorar. Si no está en buen estado (Advertencia o Error), continúe con los pasos de solución de problemas que se indican a continuación.

Solución de problemas

Busque el servidor indicado en el mensaje de alerta recibido e intente hacer ping en él:
Description><![CDATA[The EKM Server: ecs-dev-keysecure-xx.xxx.xx.xxx is not responding. Please ensure that the server is connected. [Ref_ID : EKMServerConnectionStatus]]]></Description>
Compruebe resourcesvc.log si hay mensajes sobre el problema Servidor de EKM:
Comando:
grep /opt/emc/caspian/fabric/agent/services/object/main/log/<EKM Server Name> resourcesvc.log
Ejemplo:
The command will return output in the following format:
There was some error verifying connection to EKMServer {will have failed server name} in cluster. {will have failure detail}
Los errores indican un posible problema de red en el entorno. Es posible que la comunicación entre ECS y el servidor de EKM esté bloqueada o que el servidor de EKM en sí no esté disponible. Verifique que ECS pueda hacer ping al servidor de EKM y recomiende al usuario que verifique que el servidor de EKM esté en funcionamiento.

Si no puede resolver el problema, abra una solicitud de servicio con el soporte de ECS para obtener asistencia con la información recopilada anteriormente.

Επηρεαζόμενα προϊόντα

ECS, ECS Appliance, ECS Software, Elastic Cloud Storage
Ιδιότητες άρθρου
Article Number: 000038620
Article Type: Solution
Τελευταία τροποποίηση: 17 Δεκ 2025
Version:  7
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