PowerPath for Windows: PowerPath rapporterer hendelse 4 – kilde: Powerpath - EMC Powerpath Error: MPAPI: Feil: Det oppstod en intern feil.

Summary: Hendelse 4 vises i Viewer, og rapporterer Corporation () PowerPath MPAPI-feil etter oppgradering til 5.7 SP2. MPAPI (Powermt, host-agent, Powermig) forårsaker feil. Ingen innvirkning på PowerPath-klynge. ...

Αυτό το άρθρο ισχύει για Αυτό το άρθρο δεν ισχύει για Αυτό το άρθρο δεν συνδέεται με κάποιο συγκεκριμένο προϊόν. Δεν προσδιορίζονται όλες οι εκδόσεις προϊόντων σε αυτό το άρθρο.

Symptoms



PowerPath for Windows

PowerPath rapporterer hendelse 4 – kilde: Powerpath - EMC PowerPath Error: MPAPI: Feil: Det oppstod en intern feil.

Denne hendelsen rapporteres hver time i Windows Event Viewer.
Selv om hendelsen rapporteres hver time, er det ingen problemer med PowerPath og klyngefunksjonalitet.
Hendelsen startet etter oppgradering av PowerPath fra 5.5 til 5.7 SP2.

Cause

Klienter for MPAPI er Powermt, Host agent service og Powermig service fører til at hendelsen oppstår i hendelseslisten.

Resolution

Deaktiver funksjonen for automatisk vertsregistrering og se om problemet er løst.
Hvis du vil deaktivere registrering av automatisk vert, reparerer du installasjonen av PowerPath ved hjelp av CLI hvis PowerPath-versjonen er 5.7 SP4 eller eldre: 
C:\EMCPower.X64.signed.5.7.SP2.bxxx.exe /s /v"/L*v C:\logs\PPrepair.log REINSTALL=ALL AUTO_HOST_REGISTRATION=0 NO_REBOOT=1"

I PowerPath 6.0 kan registrering av automatisk vert deaktiveres av powermt-kommandoen:
PowerMT-sett auto_host_registration={på|av} 

Hvis problemet vedvarer, oppgraderer du PowerPath til 6.0 eller nyere, da det er mulighet for at dll-filen blir inkonsekvent under oppgraderingen, og PowerPath 6.0 skal ikke ha dette problemet.

Additional Information

Se OPT 467881.

Επηρεαζόμενα προϊόντα

Storage Networking
Ιδιότητες άρθρου
Article Number: 000055944
Article Type: Solution
Τελευταία τροποποίηση: 10 Δεκ 2025
Version:  5
Βρείτε απαντήσεις στις ερωτήσεις σας από άλλους χρήστες της Dell
Υπηρεσίες υποστήριξης
Ελέγξτε αν η συσκευή σας καλύπτεται από τις Υπηρεσίες υποστήριξης.