Integrated Data Protection Appliance: DPSearch of Root File Displays System Low Free Space
Summary: Integrated Data Protection Appliance RUCK tool reports boot usage space warning for DPSearch control node. This results in the inability to log in to Search Web Interface and Search Server Elasticsearch, and search-cis-core services do not start. Control Search node root file system shows low or no available free space. ...
Symptoms
- Integrated Data Protection Appliance: The RUCK tool reports Boot space usage warning for the Control Search node, which must be resolved before upgrade can proceed.
- Attempting to copy the upgrade package to the Control Search node repository fails or the upgrade may not process due to lack of available free space.
- Log in to Search web interface fails with authentication errors.
|puppet agent |No Exception |Warning: Unable to fetch my node definition, but the agent run will continue: Warning: Error 400 on SERVER: No space left on device @ io_write - /var/lib/puppet/yaml/node/dpeasrchm01.biz.com.yaml20210512-2916 Error: Could not retrieve catalog from remote server: Error 400 on SERVER: No space left on device @ rb_sysopen - /var/lib/puppet/yaml/facts/dpeasrchm01.biz.com.yaml20210512-2916 Warning: Not using cache on failed catalog Error: Could not retrieve catalog; skipping run
Cause
/var/lib/puppet/reports.Resolution
./goidpa dpsearch space-fix
The puppet reports are generated to track client and server configuration in the Search cluster and are not required for normal operations.
This issue is resolved in Search versions later than 19.5, which should automatically control the max age of reports that are kept. Perform the following on the Control Search node to resolve this issue in other versions.
The commands below delete all puppet reports from older than one day:
find /var/lib/puppet/reports/ -type f -mtime +1 -name '*.yaml' -exec rm {} \;
If this does not clear enough space, we can delete the older Avamar Client that Integrated Data Protection Appliance and Search do not need:
rm -rf /usr/local/avamar_7* rm -rf /usr/local/avamar_18.* If you are on a DP8X, repeat these commands on the other two index nodes.
If this does not clear enough space, we can delete old logs:
rm /var/log/messages-2022* rm /var/log/messages-2023* rm /var/log/*.xz rm /var/log/nginx.error.log rm /var/log/nginx/error.log service nginx restart If you are on a DP8X, repeat these commands on the other two index nodes.
If this does not clear enough space, reboot the Search Node (if DP8X, reboot all three nodes)
If still not enough space, engage Dell Support to clear up extra space.