Data Protection Advisor : DPA data collection for MS SQL is not working

Summary: Data Protection Advisor : DPA data collection for MS SQL is not working

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Symptoms

After one changes the DPA agent service to run as a named user and has added the MSSQL into DPA, request history of the Job Monitor is empty. Run a modtest in GUI. The xml in it has below message.
Unable to run request mssqldb:jobmonitor as there was an error opening the required pstore <DPA_Install_dir>\EMC\DPA\agent\data\mssqldb_jobmonitor_<MSSQL_server_name>_<Instance_name>.db.</MESSAGE><REPORT>

Under folder <DPA_Install_dir>\EMC\DPA\agent\data, one cannot find the file mssqldb_jobmonitor_<MSSQL_server_name>_<Instance_name>.db.
Restarted DPA agent, still, this file is not generated. Also, the dpagent.log does not have any entry about the restarting of the agent. Even if one changes the log level in dpagent_config.xml file to Debug low then restart the agent, dpaagent.log does not have 

Cause

The product is functioning as designed.
In one instance where this was observed, the named account which DPA agent serivices runs with does not have enough privilege.

Resolution

In one instance where this was observed, issue resolved after user changed DPA agent service to run as another domain account. 

Affected Products

Data Protection Advisor

Products

Data Protection Advisor
Article Properties
Article Number: 000055127
Article Type: Solution
Last Modified: 28 Aug 2025
Version:  5
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