NetWorker: NMC cannot connect to NetWorker server, 'Unable to connect to server, Remote system error - Resource temporarily unavailable'
Summary: NMC cannot connect to NetWorker server, 'Unable to connect to server, Remote system error - Resource temporarily unavailable'. The issue is caused by ports in the NetWorker port range being blocked on the NetWorker server. ...
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Symptoms
- The NetWorker Management Console (NMC) cannot connect to both NetWorker servers. When connection to the NMC, an error appears stating:
'Unable to connect to server, Remote system error - Resource temporarily unavailable'
- The following errors are logged in the NetWorker server's /nsr/logs/daemon.raw:
173680 07/08/2019 09:08:37 PM nsrexecd RPC error RPC client handle: No route to host.
172089 07/08/2019 09:08:37 PM nsrexecd RPC error Unable to create the connection with '' to host (NetWorker server) with address (ip-address of NetWorker server) at port number 0.
173678 07/08/2019 09:08:37 PM nsrexecd RPC critical Check whether the firewall is blocking the client ports on the host (ip-address of NetWorker server).
- Name resolution, ping, and traceroute work fine.
nsrportsconnection to the NetWorker server client port times out or is rejected:
nsrports -t localhost -p 7938
- NetWorker services are running on the NetWorker server:
- Linux:
ps -ef | grep nsr - Windows:
tasklist | findstr nsr
- Linux:
- The
nsrrpcinfocommand on the NetWorker server shows which ports the server processes are using:
nve:~ # nsrrpcinfo -p localhost PROGRAM VERSION PROTOCOL PORT SERVICE 100000 2 tcp 7938 nsrportmapper Port Mapper 100000 2 udp 7938 nsrportmapper Port Mapper 390436 1 tcp 9160 nsrexecd GSS Authentication 390435 1 tcp 9530 nsrexecd Resource Mirror 390113 1 tcp 7937 nsrexecd Remote Execution 390440 1 tcp 9327 nsrexecd_nsrfa Remote File Access 390408 1 tcp 9891 nsrpsd Snapshot Management 390409 1 tcp 8955 nsrsnapckd Snapshot Management 390402 1 tcp 9001 gstd GST 390460 1 tcp 7999 auth_proxyd Authentication Proxy 390103 2 tcp 9858 nsrd Server 390109 2 tcp 9858 nsrd Remote Monitoring 390110 1 tcp 9858 nsrd Jukebox Management 390120 1 tcp 9858 nsrd License Manager 390105 5 tcp 8385 nsrindexd Index Database 390105 6 tcp 8385 nsrindexd Index Database 390107 5 tcp 8197 nsrmmdbd Media Database 390107 6 tcp 8197 nsrmmdbd Media Database 390111 1 tcp 8882 nsrsnmd Storage Node Management 390439 1 tcp 9740 nsrfa Remote File Access 390433 1 tcp 9447 nsrjobd Job Management 390114 1 tcp 7948 nsrdispd Dispatcher 390438 1 tcp 9633 nsrlogd Audit Logging 390104 205 tcp 9797 nsrmmd Media Multiplexor 390104 305 tcp 8917 nsrmmd Media Multiplexor 390104 405 tcp 9636 nsrmmd Media Multiplexor
- Remote connections from another system cannot connect to client ports on the NetWorker server:
Linux:
Windows (PowerShell):
curl -v networker_server_name:7938
Windows (PowerShell):
tnc networker_server_name -port 7938
Cause
There operating system firewall on the NetWorker server is blocking some or all the ports in the NetWorker port range, default 7937-9936.
Resolution
Ensure that the NetWorker service port range (7937-9936) is open in the operating system firewall. Consult with the operating system documentation and administrator for configuring the operating system firewall.
Other ports may be required depending on the services and purpose of the host. See: NetWorker Processes and Ports
NOTE: Microsoft Windows installations have an option in the installation wizard "configure the OS firewall." It is highly recommended to use this option so that default ports are allowed through the firewall. If this option was not used, firewall rules must be created to allow ports in the NetWorker port range.
If the issue continues after adjusting OS firewall rules, consult the network administrator to check for external firewalls blocking NetWorker ports.
Affected Products
NetWorkerProducts
NetWorkerArticle Properties
Article Number: 000060670
Article Type: Solution
Last Modified: 12 June 2025
Version: 4
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