Avamar : Server 19.10+ with avtar Client Authentication Failure with Error 69
Summary: When using Avamar with a client version prior to 19.10, passwords longer than 20 characters may be truncated, resulting in authentication failures. This issue is specific to local users and does not affect users created from LDAP. To resolve this issue, ensure that the client version matches the server version or shorten the password. If the client version is earlier than 19.10.100, passwords longer than 20 characters will be truncated, and authentication will fail. This limitation applies to all local users, including Avamar root and MCUser. ...
This article applies to
This article does not apply to
This article is not tied to any specific product.
Not all product versions are identified in this article.
Symptoms
The Symptoms of the issue are as follows:
- The Avamar server login fails even when the password is correct, resulting in an authentication failure (Invalid password? User disabled?) error.
- The encoded password does not work, even when used in place of the clear text password.
- The issue occurs when the password is longer than 20 characters.
- The issue occurs when the Avamar server version is 19.10 or higher, and client is running an older version.
- The following error messages are displayed:
-
avtar Error <5126>: Login error 69: Authentication failure (Invalid password? User disabled?) avtar FATAL <5308>: Failed to initiate session with server avtar Info <6149>: Error summary: 2 errors: 5308, 5126 avtar Info <5314>: Command failed (2 errors, exit code 10008: cannot establish connection with server (possible network or DNS failure))
-
Cause
This specific issue with the avtar authentication failure is caused by either of these two scenarios:
- Password length: The password used is too long, exceeding the 20-character limit in older versions of Avamar.
- Version mismatch: The client and server versions not matching, which is a requirement for Avamar authentication due to the new, longer, character limit.
Resolution
- Ensure that the client and server versions match for the Avamar client to authenticate with the Avamar server.
- Use a password that is 27 characters or less for the Avamar client to authenticate with the Avamar server when the client and server versions do not match.
- Run the
avtar --backupscommand on the Avamar server using the clear text password to troubleshoot authentication issues.avtar --backups --id=exampleuser --ap=examplepassword --path=/path/to/client --server=192.168.1.1 # Replace with Avamar IP or FQDN
If you are still experiencing issues with password authentication, contact Dell Support for assistance.
Affected Products
Avamar Client, Avamar Client for Linux, UNIX, MacOSX, Avamar Plug-in for IBM DB2, Avamar Plug-in for Oracle, Avamar ServerArticle Properties
Article Number: 000229108
Article Type: Solution
Last Modified: 27 Sept 2024
Version: 1
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.