Data Protection Central: UI Login Fails with "401 Unauthorized"

Summary: After a DPC or IDPA upgrade, users may be unable to log in to the Data Protection Center (DPC) UI. The login failure is a result of a synchronization issue between the Identity and Access Management (IAM) service and Keycloak. ...

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Symptoms

  • DPC UI login fails with a 401 Unauthorized error.

  • The following errors appear in the IAM service log (/var/log/dpc/iam/iam-service/iam-services.log):

    • WebClientRequestException: finishConnect(..) failed: Connection refused: iam-provider:<IPv6>:8443
      IAMExchangeException(errorMessage=Cannot get admin access token, httpStatus=401 UNAUTHORIZED)

Cause

The issue is caused by a password synchronization failure between the IAM service and the Keycloak identity provider.
This prevents the IAM service from obtaining the necessary admin access token, resulting in login failure.

Resolution

This issue requires intervention from Dell Support.
To resolve the problem:

  1. Do not attempt to restart services or modify IAM/Keycloak configurations manually.
  2. Open a service request with Dell Support and reference this KB Article (#000375379) to expedite the resolution.

Dell Support performs the necessary backend operations to restore synchronization and resolve the login issue.

Affected Products

Data Protection Central
Article Properties
Article Number: 000375379
Article Type: Solution
Last Modified: 05 Nov 2025
Version:  1
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