NVP vProxy: La solución de problemas de respaldos de VM falla con el mensaje "VDDK Error 13: No tiene derechos de acceso a este archivo"

Summary: El dispositivo vProxy de NetWorker VMware Protection (NVP) no puede respaldar uno o más discos duros. El error devuelto es el error 13 de VDDK "No tiene derechos de acceso a este archivo". Este es un error general que se traduce como "No puedo acceder a este archivo". Las causas comunes son problemas de comunicación, permisos o configuración. ...

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms

Los respaldos de máquinas virtuales de VMware fallan con lo siguiente:

Failed to backup virtual disk "Hard disk #".  Failed to initialize Block Reader.  Failed to open source VMDK '[DATASTORE] VM_NAME/VM_NAME.vmdk': VDDK Error: 13: You do not have access rights to this file.

Este mensaje se puede encontrar en el registro de la sesión de respaldo de la máquina virtual (VM) como se ve a través de los detalles de la acción de respaldo de NetWorker Management Console (NMC). Los registros de sesiones de VM también se almacenan en las siguientes ubicaciones:

Servidor NetWorker: /nsr/logs/policy/POLICY_NAME/WORKFLOW_NAME/
dispositivo vProxy: /opt/emc/vproxy/runtime/logs/recycle/vbackupd/DATE

Cause

VMware informa este error del kit de desarrollo de discos virtuales (VDDK) a vProxy. El error 13 es un error de acceso general que indica que hay problemas de permisos o comunicaciones que impiden que el vProxy acceda correctamente a los archivos de la máquina virtual. 

Resolution

NOTA: Los artículos específicos del problema se pueden encontrar en la sección Información adicional de este artículo. La mayoría de las causas de este error se pueden identificar mediante la utilidad ProxyHC. En algunos casos, la utilidad ProxyHC puede resolver los problemas que provocan la aparición de esta falla.

Obtener ProxyHC y transferirlo al vProxy:

ProxyHC se puede recopilar en la página Herramientas de NetWorker orientada al cliente: https://central.dell.com/solutions/Networker-Tools

Copiar ProxyHC en el dispositivo vProxy:

el paquete se puede copiar en el dispositivo vProxy mediante un agente SCP (WinSCP, FileZilla, etc.). 

Usuario: admin (la raíz está bloqueada a través de SSH de manera predeterminada).
Protocolo: SCP

O desde la línea de comandos de Windows (si tiene instalado Server 2019 o posterior, u OpenSSH).
scp source admin@vProxy_address:/home/admin/ProxyHC
Donde source es la ruta completa al archivo ProxyHC extraído en el sistema Windows.

Puede encontrar instrucciones adicionales para copiar archivos en un sistema Linux en:  
NetWorker (Linux): Cómo copiar archivos hacia y desde un servidor NetWorker Server de Linux.

Uso de ProxyHC:

Confirme que no haya respaldos de VM en ejecución a través del dispositivo vProxy y realice lo siguiente:
  1. Conéctese al vProxy a través de SSH con la cuenta de administrador.
  2. Cambie al usuario raíz:
sudo su -
  1. Haga que ProxyHC sea ejecutable:
chmod +x /home/admin/ProxyHC
  1.  Ejecute ProxyHC con las siguientes marcas: 
/home/admin/ProxyHC auth port perm tasks disk cleanup hotadd
 
ProxyHC Switches
auth Solicita al usuario que valide las credenciales de administrador y la autenticación de NetWorker con vCenter. Ingrese la cuenta de usuario de vCenter que se utiliza para agregar vCenter a VMware View de NMC.
port Compruebe la comunicación de puertos necesaria entre el dispositivo vProxy, Data Domain, los hosts ESXi y vCenter.
perm Esto identifica si al usuario de vCenter le faltan los permisos necesarios para ejecutar respaldos.
tasks Compruebe si hay tareas de respaldo huérfanas en vCenter.
cleanup Compruebe si existen artefactos sobrantes de respaldos anteriores: discos, bloqueos, anotaciones. Se le pregunta si desea corregir todos los vProxies en vCenter. Si no hay operaciones de respaldo/restauración de VM en ejecución, ingrese Y. Si otros vProxies están realizando operaciones de respaldo/restauración, ingrese N.
hotadd Ingrese el nombre de DNS (no el nombre de VM). El nombre DNS de la VM se puede consultar mediante el comando nslookup o en el campo DNS de la pestaña VMs summary en vSphere. Esto comprueba que el vProxy tenga acceso de adición en caliente a los archivos de la VM.


Si la marca de limpieza indica que se realizaron operaciones (eliminación de discos, liberación de bloqueos, borrado de anotaciones), vuelva a intentar el respaldo. Si se informa alguna falla, revise /tmp/proxy-hc.log del vProxy. El resultado identifica lo que falta y lo que se necesita, o bien aísla "no tiene derechos de acceso" a una causa específica. Las referencias para causas específicas se pueden encontrar en "Información adicional".
 

Additional Information

KB con causas específicas para el error 13 de VDDK:

Recursos adicionales:

Otras opciones para ProxyHC:

usage: ProxyHC vCenter [-h] --name NAME --user USER [--pwd PWD] [--vm VM]
                       [--nsruser NSRUSER] [--nsrpwd NSRPWD]
                       [--nsrauthc NSRAUTHC] [--allproxies ALLPROXIES]
                       [--DDhost DDHOST]
                       {auth,port,perm,disk,hotadd,migration,listsession,annotation,cleanup,kb524127,all,layout,tasks,datastore,vmsnapchain,vmdisksize,termsoapsession}
                       ...

positional arguments:
  {auth,port,perm,disk,hotadd,migration,listsession,annotation,cleanup,kb524127,all,layout,tasks,datastore,vmsnapchain,vmdisksize,termsoapsession}
                        sub-command help
    auth                test authentication against vCenter server
    port                check open ports to ESXi hosts in cluster and data
                        domain systems
    perm                check vCenter access permissions
    disk                check & release extra disks from vProxy
    hotadd              check for hotadd access to provided VM
    migration           check vCenter for stale migration locks
    listsession         print login session list to log
    annotation          check vCenter for stale backup locks(annotations)
    cleanup             remove left over artifacts(extra disks,
                        locks/annotations) and find migration locks.
    kb524127            check for invalid state of vProxy VM
    all                 All vCenter tools(combination of port, perm and
                        cleanup)
    layout              check for description of files that make up VM
    tasks               check orphaned tasks in vCenter
    datastore           look for datastores with unsupported names
    vmsnapchain         check if any protected VM has excessive child disks
    vmdisksize          check if any protected VM has irregular disk size i.e.
                        trailing .5 KB
    termsoapsession     terminate soap session to vCenter from NWS

optional arguments:
  -h, --help            show this help message and exit
  --name NAME           hostname of the vCenter server
  --user USER           user name for login to vCenter server
  --pwd PWD             password for login to vCenter server
  --vm VM               DNS name of VM(as shown in vSphere)
  --nsruser NSRUSER     user name for login to NetWorker server
  --nsrpwd NSRPWD       password for login to NetWorker server
  --nsrauthc NSRAUTHC   Remote AuthC server
  --allproxies ALLPROXIES
                        specify to do work on peer vProxies registered
  --DDhost DDHOST       provide DD IP/hostname for port connectivity tests

Affected Products

NetWorker

Products

NetWorker Family, NetWorker Series
Article Properties
Article Number: 000207076
Article Type: Solution
Last Modified: 24 Oct 2025
Version:  8
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.