NVP-vProxy: VM disk failing to backup with "VDDK Error: 13: You do not have access rights to this file....mount point already exists"
Summary: You are backing up a Virtual Machine (VM) with the NetWorker VMware Protection (NVP) vProxy appliance but one or more VM disks are failing to backup. The failure reports "VDDK Error: 13: You do not have access rights to this file." This is a general error which can appear for several symptoms. In this scenario, the vProxy vbackupd-vddk.log indicates that the mount point already exists. This occurs when a VM .vmdk file was left attached to a vProxy. ...
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Symptoms
The NetWorker VMware Protection integration is configured with the vProxy Appliance. The backup of a virtual machine (VM) fails to backup a specific disk (.vmdk). The failure in the NetWorker Management Console (NMC) reports "Unable to backup virtual disk "Hard Disk #"" with no additional information.
The backup session logs on the NetWorker server or vProxy show the following for the affected .vmdk:
Linux: /nsr/logs/policy/policy_name
Windows (Default): C:\Program Files\EMC NetWorker\nsr\logs\policy\policy_name
vProxy: /opt/emc/vproxy/runtime/logs/recycle/vbackupd/DATE/
YYYY/MM/DD HH:MM:SS ERROR: [194] Failed to open source VMDK "[DATASTORE] VM_NAME/VM_NAME_1.vmdk": VDDK Error: 13: You do not have access rights to this file.
YYYY/MM/DD HH:MM:SS ERROR: [194] "Hard disk 2": BackupVmdk: "Hard disk 2": Unable to open Virtual Disk "[DATASTORE] VM_NAME/VM_NAME_1.vmdk" in "hotadd" mode.
YYYY/MM/DD HH:MM:SS ERROR: [194] "Hard disk 2": BackupVmdk: "Hard disk 2": Unable to open Virtual Disk "[DATASTORE] VM_NAME/VM_NAME_1.vmdk" in "hotadd" mode.
YYYY/MM/DD HH:MM:SS ERROR: [194] "Hard disk 2": BackupVmdk: Failed backup.
On the vProxy, the /opt/emc/vproxy/runtime/logs/vbackupd-vddk.log shows:
YYYY/MM/DD HH:MM:SS NOTICE: VDDK INFO VixDiskLib: VixDiskLib_OpenEx: Cannot open disk [DATASTORE] VM_NAME/VM_NAME_1.vmdk. Error 13 (You do not have access rights to this file) (Mounting VM vm-### using transport hotadd failed : Mount point "/tmp/vmware-root/50268f14....177-vm-###/hotadd" already exists..) at 5026.
YYYY/MM/DD HH:MM:SS NOTICE: VDDK INFO VixDiskLib: VixDiskLib_Open: Cannot open disk [DATASTORE] VM_NAME/VM_NAME_1.vmdk. Error 13 (You do not have access rights to this file) at 5064.
YYYY/MM/DD HH:MM:SS NOTICE: VDDK INFO VixDiskLib: VixDiskLib_Disconnect: Disconnect.
Cause
The VM's .vmdk was left attached to the vProxy appliance after a previous backup, resulting in the error "Mount point xxxxx already exists."
Resolution
There are two options available.
Option 1:
Use the ProxyHC utility to cleanup the left behind disks.
NVP-vProxy: How to use health check tool ProxyHC on vProxy appliance
The above KB details how to get and use the ProxyHC tool. The syntax needed for this specific issue is:
NVP-vProxy: How to use health check tool ProxyHC on vProxy appliance
The above KB details how to get and use the ProxyHC tool. The syntax needed for this specific issue is:
./ProxyHC tasks disk cleanup
Option 2:
Manual cleanup of the vProxy's configured disks. The additional .vmdk's must be detached from the vProxy appliance. If the vProxy is performing no backup or restores, the vProxy appliance should only have its two .vmdk's attached to the vProxy appliance VM.
1. Stop VM backups going through the vProxy reporting the "Mount point xxxxxx already exists" error.
2. Log in to the vCenter's vSphere web client.
3. Right-click the vProxy appliance and select "Edit Settings..."
4. Check for any disks belonging to other VMs:
2. Log in to the vCenter's vSphere web client.
3. Right-click the vProxy appliance and select "Edit Settings..."
4. Check for any disks belonging to other VMs:
5. If there are any additional .vmdk disks attached to the vProxy appliance, make note of the VM name and detach the disks. The .vmdk's contain the name of the vSphere VM display name (or another VM name other than the vProxy's name).
CAUTION: Do not use the "delete from datastore" option. The disk must be detached from the vProxy, not deleted from storage. Do not remove any of the disks that belong to the vProxy.
6. From vSphere, search for the VM whose disks were detached from the vProxy.
7. In the VM's Summary tab, click Edit under Custom Attributes.
8. Select each of the attributes containing "Dell EMC vProxy" and Delete them. They will be re-created during the next vProxy action. Deleting the attributes ensures that any stale session information is cleaned up.
9. Reboot the vProxy appliance.
Additional Information
NOTE: The "VDDK Error 13" is a general error returned from VMware. The vProxy /opt/emc/vproxy/runtime/logs/vbackupd-vddk.log provides more insight about the specific cause. The following articles should also be reviewed if this article is not applicable.
- NetWorker NVP-vProxy: Backups fail with the error: VDDK Error: 13: "You do not have access rights to this file." "Failed to allocate SCSI target ID"
- NVP vProxy: VM Backups Fail With "VDDK Error: 13: You do not have access rights to this file…unable to open virtual disk in hot add mode"
- NVP vProxy: VM backups fail with "VDDK Error 13: You do not have access rights to this file" - Troubleshooting/Triage Guide.
Affected Products
NetWorkerProducts
NetWorkerArticle Properties
Article Number: 000031379
Article Type: Solution
Last Modified: 24 Oct 2025
Version: 6
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