ECS: Unable to create SAML Service Provider from UI receiving "Error 7000 (http: 400): InvalidResponse ... (Svarar inte)
Summary: Målet är att generera en "SAML Service Provider Metadata"-fil för att använda S3-autentisering på ECS med Microsoft ADFS. Det kan misslyckas enligt beskrivningen. I den här kunskapsartikeln finns en tillfällig lösning endast för 3.7. För 3.6 läser du avsnittet Lösning. ...
This article applies to
This article does not apply to
This article is not tied to any specific product.
Not all product versions are identified in this article.
Symptoms
Steg för att återskapa:
- Logga in på ECS-gränssnittet.
- Navigera till Manage->Identity and Access (S3).
- Klicka på metadata för SAML-tjänstprovider.
- Ladda upp Xml- eller txt-filen med Java-nyckel.
- Ange nyckelalias, nyckellösenord, DNS-bas-URL och klicka på Generate.
Det ger felmeddelandet "Error 7000 (http: 500): InvalidResponse Error occurred, see ecs logs for details." eller "Error 7000 (http: 400): InvalidResponse Error occurred, see ecs logs for details."
Felmeddelandet är inte specifikt och användaren kan inte identifiera vad som gått fel.

Cause
Vi har två separata API:er för att skapa (POST) och uppdatera (PUT) tjänsteleverantör. Problemet ligger hos användargränssnittet. Om det inte fungerar att skicka uppdateringstjänstleverantören och serverdel inte hittar nyckeln för tjänsteleverantören eftersom det inte finns någon.
Resolution
När du stöter på det här problemet är lösningen att klicka på Delete Metadata och sedan förstår och skickar användargränssnittet postförfrågan för att skapa en tjänsteleverantör.
En framtida ECS-version innehåller en korrigering av problemet.
För 3.6 är Delete metadata nedtonade som standard, som förväntat, eftersom det inte finns några metadata. Om användarna får samma fel kontrollerar du att nyckeln är 64base.
Additional Information
Se bifogad PDF: DellEMC-ECS_IAMandHadoopS3A_Implementation.pdf
Affected Products
Elastic Cloud StorageProducts
ECS, ECS ApplianceArticle Properties
Article Number: 000207887
Article Type: Solution
Last Modified: 19 Jul 2023
Version: 5
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.