PowerStore: Artículo general sobre reinicios inesperados del nodo
Summary: Para identificar completamente la causa de un reinicio o proporcionar un análisis de causa raíz (RCA) completo, se necesitan varios registros.
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Symptoms
El evento o el código de error más probables para este problema son los siguientes: 0x00304404
Descripción: El nodo se quitó físicamente o se apagó.
Ejemplo como se muestra en PowerStore Manager:
AVISO: Un reinicio de nodo puede activar otras alertas secundarias o devoluciones, como las siguientes:
Descripción: El nodo se quitó físicamente o se apagó.
Ejemplo como se muestra en PowerStore Manager:
AVISO: Un reinicio de nodo puede activar otras alertas secundarias o devoluciones, como las siguientes:
- Alertas de falla del enlace de puerto (Código de evento 0x00307404). Más detalles en Alertas de PowerStore: Falla de enlace de puerto.
- Alertas de estado del puerto (códigos de eventos: 0x00305302, 0x00305303, 0x00305402, 0x00305403). Más detalles en Alertas de PowerStore: Estados del puerto del nodo
NOTA: La mayoría de los reinicios de nodos se corrigen mediante la actualización a la versión más reciente de PowerStoreOS. Consulte la sección 1 de PowerStore: Centro de información - documentación del producto y videos.
Cause
Un nodo de PowerStore puede reiniciarse inesperadamente debido a diversos motivos.
Cada reinicio inesperado se debe investigar por separado.
Consulte la sección Información adicional a continuación a fin de obtener detalles sobre lo que se necesita para esta investigación.
Cada reinicio inesperado se debe investigar por separado.
Consulte la sección Información adicional a continuación a fin de obtener detalles sobre lo que se necesita para esta investigación.
Resolution
Existen algunas opciones para comprobar si hay reinicios inesperados del nodo.
Inicie sesión en el clúster mediante ssh y ejecute svc_dc list_dumps
También puede intentar encontrar archivos de volcado desde PowerStore Manager. Para obtener más información, consulte PowerStore: Cómo generar y recopilar varios registros de PowerStore.
Para iniciar sesión en los nodos mediante ssh, busque la IP del clúster o del nodo en PowerStore Manager en Settings > Network IPs. Inicie sesión con su cliente ssh preferido mediante la cuenta de usuario de servicio y la contraseña de usuario de servicio correspondiente (definida durante la configuración del sistema).
Esto también es útil, ya que es posible que algunos reinicios inesperados no produzcan un archivo de volcado.
Comprobación de alertas y eventos desde PowerStore Manager (GUI)
Compruebe los eventos y las alertas que podrían indicar un reinicio inesperado del nodo:- En PowerStore Manager, revise la sección Monitoring y observe los detalles en las pestañas ALERTS y EVENTS.
- Busque registros de fecha y hora, códigos de error o eventos, mensajes, etc. Para que las búsquedas sean más claras, utilice las opciones de filtro de las pestañas ALERTS y EVENTS:
Comprobación de archivos de volcado
Compruebe la existencia de archivos de volcado del sistema en el momento de los errores.Inicie sesión en el clúster mediante ssh y ejecute svc_dc list_dumps
También puede intentar encontrar archivos de volcado desde PowerStore Manager. Para obtener más información, consulte PowerStore: Cómo generar y recopilar varios registros de PowerStore.
Para iniciar sesión en los nodos mediante ssh, busque la IP del clúster o del nodo en PowerStore Manager en Settings > Network IPs. Inicie sesión con su cliente ssh preferido mediante la cuenta de usuario de servicio y la contraseña de usuario de servicio correspondiente (definida durante la configuración del sistema).
Comprobación del tiempo de actividad en ambos nodos
Ejecute el comando uptime en ambos nodos. Esto le indicará cuánto tiempo ha estado activo el nodo y lo ayudará a confirmar posibles reinicios.Esto también es útil, ya que es posible que algunos reinicios inesperados no produzcan un archivo de volcado.
Otros indicadores
Una brecha en los gráficos de rendimiento en PowerStore Manager también puede indicar un reinicio del nodo. Esto se debe utilizar solo como orientación y debe confirmar con más pruebas como se indicó anteriormente. Los gráficos de rendimiento están disponibles en Dashboard > PERFORMANCE, o en Hardware > Appliance X > Performance.Additional Information
¿Qué se necesita para el Análisis de causa raíz (RCA)?
- Materiales de soporte de todos los dispositivos del clúster. Estos se deben recopilar lo más cerca posible del reinicio.
- Archivo de volcado
Affected Products
PowerStoreArticle Properties
Article Number: 000130141
Article Type: Solution
Last Modified: 16 Aug 2023
Version: 14
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