MHC Azure Stack: OEM Type FirmwareCheckHealth of Role OEM raised an exception

Summary: Type FirmwareCheckHealth of Role OEM raised an exception Error running Test-OEMFirmwareHealth iDRAC has Critical Major faults could not proceed with Firmware update.

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms

Precheck of OEM is failing Errors:
Oem Package Update
Perform Oem Extension update.

BeforeOEMUpdate
Tasks before OEMUpdate.

Test Firmware PreUpdate
Determine if OEM Firmware should be updated on physical nodes.

Firmware Check Health.
Check firmware health before update.

OEM.png

Click "Download Summary".

Error.json: 
Type ‘FirmwareCheckHealth’ of Role ‘OEM’ raised an exception:\n\nError running Test-OEMFirmwareHealth: iDRAC: 10.224.190.3 has Critical Major faults, could not proceed with Firmware update….

OEMerror.png
 

Cause

Three of the four servers had memory errors. These need to be resolved before proceeding. 
The memory health monitor feature has detected a degradation in the DIMM installed in DIMM_A6. Reboot system to initiate self-heal process.

Resolution

To resolve this issue, fix the memory errors.

  1. Drain the node with the iDRAC showing the failed memory. 
  2. Once drained, run the following commands in a PEP PowerShell window. 
get-virtualdisk -cimsession "s-cluster"
get-virtualdisk -cimsession "s-cluster" | get-storagejob
  1. Once all storage jobs are complete, cold boot the server from the iDRAC
  2. Verify that the DIMM has healed:
    The self-heal operation successfully completed at DIMM DIMM_A6.
  3. In the Azure Stack window, Start the node.
  4. In the Azure Stack window, Resume the node.

Affected Products

Integrated System for Microsoft Azure Stack Hub, Integrated System for Microsoft Azure Stack Hub 14G
Article Properties
Article Number: 000200301
Article Type: Solution
Last Modified: 08 Sept 2025
Version:  3
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.