Dell Thunderbolt Dock WD22TB4 May Have USB Ports Fail When a Powered Device is Connected
Summary: Learn about what to do if a Dell Thunderbolt WD22TB4 dock’s USB ports stop working after connecting a powered device.
Symptoms
When a powered device (such as a powered speaker) is plugged in to a Dell Thunderbolt Dock - WD22TB4, the USB ports may stop working.
Affected Devices:
- Dell Thunderbolt Dock - WD22TB4
Cause
This is not due to a Dell hardware failure. Several security software suites can block Thunderbolt 4 (TB4) functionality.
Resolution
Check if releasing the flea power allows powered devices to work. If not, try temporarily disabling the security software. For more information, reference the steps below.
Release flea power on the Dell Thunderbolt Dock - WD22TB4
- Remove the dock USB Type-C or Thunderbolt cable from the computer.
- Unplug AC power from the dock.
- Drain any remaining power to the dock by holding the power button for 30 seconds.
- Plug AC power into the dock.
- The dock LED on the power button should blink three times.
- Plug the dock’s USB Type-C or Thunderbolt cable back into the computer.
Temporarily disable security software
Test to find out if an installed security suite software is causing the issue by temporarily disabling your security suite software. If temporarily disabling the security suite software causes the USB ports to function once again, the security software suite is blocking the dock’s TB4 functionality.
Some software security suites may allow the dock to be allowlisted. If allowlisting the dock in the software security suite is not an option, contact the software security suite vendor for further troubleshooting options.