NVE: NetWorker Installation Manager non mostra alcuna cronologia
Summary: NetWorker Virtual Edition (NVE) Installation Manager è accessibile da un web browser; Tuttavia, la scheda History non mostra alcun contenuto.
Symptoms
Ci sono vari sintomi, una combinazione o tutti possono essere osservati.
- "NetWorker Installation Manager" viene visualizzato come "Avamar Installation Manager".
- Se si tenta di caricare un pacchetto di upgrade NVE (AVP) nel repository, viene restituito l'errore "Invalid Sysinfo".
- NetWorker Installation Manager non mostra alcun contenuto nella scheda Cronologia.
Potresti anche ricevere un avviso che dice "Server is not responding. You are now logged out of the Installation Manager" e vengono reindirizzati alla pagina predefinita.
Il server NetWorker è operativo. Non vi è alcun impatto sulle operazioni di protezione dei dati, solo Installation Manager non visualizza la cronologia di installazione di NVE.
Cause
Il file avidb è danneggiato. Esistono molte potenziali cause per problemi di spazio, problemi di aggiornamento e azioni da parte dell'utente che potrebbero causare questo problema. L'obiettivo di questo articolo della KB è restituire funzionalità.
Resolution
- Aprire una sessione SSH su NVE e accedere come amministratore, quindi passare a root:
sudo su - - Prima di procedere, accertarsi che non si osservino problemi di spazio su NVE. L'avidb si trova sul mount point /space:
df -h
df -h /usr/local/avamar/var/avi/server_data
Se un volume si avvicina al 100% della capacità. Lo spazio deve essere recuperato prima di ripristinare avidb
- Convalidare se
avidbI backup sono disponibili:mminfo -avot -q client=NVER-SERVER-NAME,name=/usr/local/avamar/var/avi/server_data
Esempio di output:
azure-nve:~ # mminfo -avot -q client=azure-nve.local,name=/usr/local/avamar/var/avi/server_data volume type client date time size ssid fl lvl name .... azure_nve.local.dddefault.002 Data Domain azure-nve.local 11/09/25 17:30:05 2868 KB 3977319918 cb full /usr/local/avamar/var/avi/server_data
- Arrestare il processo di installazione AVI:
avinstaller.pl --stop - Accertarsi che il processo sia stato arrestato:
avinstaller.pl --test - Rinominare l'avidb corrente, se presente:
mv /usr/local/avamar/var/avi/server_data/avidb /usr/local/avamar/avidb_$(date -I).bak - Accedere a NetWorker Management Console (NMC) o a NetWorker Web User Interface (NWUI) per ripristinare il
avidb.- Passare alla scheda Recover e avviare il ripristino.
- Inserire il nome del client NVE.
- Seleziona una data, quindi seleziona l'icona
/space/avamar/var/avi/server_data/, quindi seleziona l'iconaavidbdi NetWorker.
NOTA: Assicurarsi di selezionare una data di "ultimo funzionamento noto". Se non è nota una data specifica, selezionare una data precedente a quando si è verificato il problema sospetto. In questo articolo vedete entrambi/usr/local/avamar/var/avi/server_data/avidbe/space/avamar/var/avi/server_data/avidbreferenziato. NVE utilizza link simbolici e il percorso /usr viene montato su /space.- Selezionare le opzioni per ripristinare il percorso originale e sovrascrivere il file esistente:
- Assegnare un nome e avviare il restor:

- Monitorare il restore. Il ripristino dovrebbe mostrare che l'operazione è riuscita:

- Avviare il programma di installazione:
avinstaller.pl --start - Verificare che il programma di installazione av esegua:
avinstaller.pl --test - Accedere alla pagina web di NetWorker Installation Manager e passare alla scheda History. Viene visualizzata la cronologia degli aggiornamenti di NVE (fino al punto di ripristino di avidb):

avidb è stato recuperato; Tuttavia, i pacchetti che sono stati installati correttamente non vengono rimossi. Se si tenta di installare nuovamente il pacchetto, verrà restituito "Already Installed". La cronologia degli aggiornamenti di NVE è disponibile anche in /usr/local/avamar/var/avi/server_data/package_data/.