NVE: NetWorker Installation Manager Web Page Is Not Accessible

Summary: The NetWorker Virtual Edition (NVE) Installation Manager (AVI) web page is not accessible. This KB describes how to troubleshoot and identify potential causes.

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms

The NetWorker server is a NetWorker Virtual Edition (NVE).

The Installation Manager (AVI) web page is not accessible.

NVE Web Interface is Unavailable with Error 503
Figure 1: NVE Web Interface is Unavailable with Error 503.

The avinstaller service is not running:

NVE:~ # avinstaller.pl --test
Avistart process:
INFO: AVI is not running.

Cause

The Installation Manager (AVI) avinstaller process is not running.

Resolution

  1. Connect to the NVE over SSH as admin.
  2. Switch to the root account:
sudo su -
    1. Ensure that the NVE does not have any full partitions:
    df -Th

    The /data01 partition can be extended: NetWorker Virtual Edition: How to increase /data01 partition size

    The / (root) partition cannot be extended. Check for files consuming space and move them to another location or remove them. The following command can be used to identify files larger than 100 MB:
    find / -size +100M -type f
    Look for large files directly on the / (sda3 device) The following file types can be removed:
    • .log
    • .raw
    • .tgz
    1. If there are no space issues on the NVE, start the avinstaller service:
    avinstaller.pl --start

    Alternatively, the following command can be used to start the service while showing debug messages:

    avinstaller.pl --debug
    1. Confirm that the avinstaller has started:
    avinstaller.pl --test
    
    1. Connect to the NVE web interface, https://NVE-HOSTNAME
    NOTE: If the Installation Manager web page is inaccessible, confirm that the port is listening and reachable from the host.
    1. Confirm if the avainstaller port (7543) is listening on the NVE:
    netstat -apno | grep 7543
    Example:
    nve:~ # netstat -apno | grep 7543
    tcp        0      0 :::7543                 :::*                    LISTEN      14411/java          off (0.00/0/0)
    nve:~ #
    nve:~ # ps -ef | grep 14411
    root      6329  6147  0 14:47 pts/1    00:00:00 grep --color=auto 14411
    avi      14411     1  0 Mar27 ?        00:04:54 java -Xmx1g -server -Djava.security.egd=file:/dev/./urandom -Dsecurity.provider.rsa.JsafeJCE.position=last -Djavax.net.ssl.trustStore=/usr/local/avamar/lib/avi/avi_keystore -Djavax.net.ssl.keyStore=/usr/local/avamar/lib/avi/avi_keystore -Xdebug -agentlib:jdwp=transport=dt_socket,address=9999,server=y,suspend=n -jar /usr/local/avamar/lib/jetty/avistart.jar
    NOTE: In the above command, port 7543 is showing "LISTEN" which indicates that the avinstaller is running and the port is listening for requests. The netstat command also lists the Process ID (PID) of the avinstaller process. Using the ps -ef command, the PID is associated with the avinstaller process.
    1. Confirm that the NVE can connect to the avinstaller process locally:
    curl -v localhost:7543
    Example:
    nve:~ # curl -v localhost:7543
    *   Trying 127.0.0.1:7543...
    * Connected to localhost (127.0.0.1) port 7543 (#0)
    > GET / HTTP/1.1
    > Host: localhost:7543
    > User-Agent: curl/8.0.1
    > Accept: */*
    >
    * Received HTTP/0.9 when not allowed
    * Closing connection 0
    curl: (1) Received HTTP/0.9 when not allowed
    1. From the host used to access the avinstaller web UI, confirm that you can resolve the NVE address and connect to the avinstaller port. This can be done using the tnc command from PowerShell:
    tnc NVE_ADDRESS -p 7543
    Example:
    tnc example
     
    NOTE: If the avinstaller process is listening but you are not able to resolve the NVE or connect to the port from a remote host, the issue is outside of NetWorker. Ensure that the host used to access the avinstaller can resolve the NVE name or use the IP address to access the avinstaller UI. The IP address must be accessible from the host used to access the UI. If name resolution is working but the connection to port 7543 fails, consult with your network or security team regarding this connection. This port is required to access the avinstaller UI. Alternatively, access the avinstaller UI from another host which can access port 7543 on the NVE.

    Additional Information

    If the Installation Manager web page fails to start or is not functioning correctly, review the following logs:

    • /usr/local/avamar/lib/jetty/logs/
    • /space/avamar/var/avi/server_log/
    • /var/log/messages

    Additional articles:

    Affected Products

    NetWorker

    Products

    NetWorker Family, NetWorker Series
    Article Properties
    Article Number: 000213100
    Article Type: Solution
    Last Modified: 10 Nov 2025
    Version:  9
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