NVE: The NetWorker Installation Manager Shows No History

Summary: The NetWorker Virtual Edition (NVE) Installation Manager Is accessible from a web browser; however, the history tab shows no contents.

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms

There are various symptoms, a combination or all may be observed.

  • The "NetWorker Installation Manager" appears as the "Avamar Installation Manager."
  • Attempting to load a NVE upgrade (AVP) package into the repository returns an "Invalid Sysinfo" error.
  • The NetWorker Installation Manager shows no contents in the history tab. 
    NVE installation manager 

You may also receive an alert that says "Server is not responding. You are now logged out of the Installation Manager" and are redirected back to the default page.

The NetWorker server is operational. There is no impact to data protection operations, only the installation manager is not displaying the NVE's installation history.

Cause

The avidb has become corrupted. There are many potential causes for space issues, upgrade issues, and user action that may result in this. The focus of this KB is to return functionality.

Resolution

  1. Open an SSH session to the NVE and log in as admin, then switch to root: sudo su -
  2. Before proceeding, ensure that no space issues are observed on the NVE. The avidb is on the /space mountpoint:

df -h

df -h /usr/local/avamar/var/avi/server_data

If any volume is nearing 100% capacity. Space must be reclaimed before recovering avidb

  1. Validate if avidb backups are available: mminfo -avot -q client=NVER-SERVER-NAME,name=/usr/local/avamar/var/avi/server_data
NOTE: Replace NVE-SERVER-NAME with the NetWorker client name of the NVE. For example, if the NVE client uses Fully Qualified Domain Name (FQDN), use that. If the NVE client uses shortname, use that instead. The client name is visible from the NetWorker Management Console (NMC) or NetWorker Web User Interface (NWUI) under Protection->Clients.

Example output:

azure-nve:~ # mminfo -avot -q client=azure-nve.local,name=/usr/local/avamar/var/avi/server_data
 volume        type   client           date     time         size ssid      fl   lvl name
....
azure_nve.local.dddefault.002 Data Domain azure-nve.local 11/09/25 17:30:05 2868 KB 3977319918 cb full /usr/local/avamar/var/avi/server_data
WARNING: It is only possible to recover avidb if you are performing Server Protection->NVE Server backup jobs. This is a default policy on NVEs; however, backups must be maintained by the backup administrator and available. Without these backups, it is not possible to recover avidb.
  1. Stop the avinstaller process: avinstaller.pl --stop
  2. Ensure that the process has stopped: avinstaller.pl --test
  3. Rename the current avidb if it exists: mv /usr/local/avamar/var/avi/server_data/avidb /usr/local/avamar/avidb_$(date -I).bak
  4. Log in to the NetWorker Management Console (NMC) or NetWorker Web User Interface (NWUI) to recover the avidb.
    1. Go to the recover tab and start the recovery.
    2. Enter the NVE client's name.
    3. Select a date then select the /space/avamar/var/avi/server_data/ folder, then select the avidb file.
      Selecting avidb save set 
    NOTE: Ensure that you select a "last known working" date. If a specific date is not known, select a date prior to when the suspected issue appeared. In this article you see both /usr/local/avamar/var/avi/server_data/avidb and /space/avamar/var/avi/server_data/avidb referenced. The NVE uses symbolic links and the /usr path is mounted on /space.
    1. Select the options to recover to the original path and overwrite the existing file:
      Overwrite existing file 
    2. Name and start the restor:

Restore

  1. Monitor the restore. The restore should show that it succeeded:

Restore session

  1. Start avinstaller: avinstaller.pl --start
  2. Ensure that the avinstaller is running: avinstaller.pl --test
  3. Log in to the NetWorker Installation Manager web page and go to the History tab. The NVE's upgrade history (up to the point of avidb recovery) is shown:

NVE Installation Manager

NOTE: The History tab will not list any packages that were installed after the date from which the avidb was recovered; however, the packages that have been successfully installed are not removed. If you attempt to install the package again it will return "Already Installed." The NVE upgrade history can also be found under /usr/local/avamar/var/avi/server_data/package_data/.

Additional Information

Affected Products

NetWorker

Products

NetWorker Family
Article Properties
Article Number: 000390175
Article Type: Solution
Last Modified: 13 Nov 2025
Version:  4
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