NVE: NetWorker Installation Manager no muestra historial
Summary: Se puede acceder a NetWorker Virtual Edition (NVE) Installation Manager desde un navegador web; Sin embargo, la pestaña Historial no muestra ningún contenido.
Symptoms
Hay varios síntomas, se puede observar una combinación o todos.
- NetWorker Installation Manager aparece como "Avamar Installation Manager".
- El intento de cargar un paquete de actualización de NVE (AVP) en el repositorio arroja un error "Sysinfo no válido".
- NetWorker Installation Manager no muestra contenido en la pestaña History.
También puede recibir una alerta que dice "Server is not responding. You are now logged out of the Installation Manager" y se redirigen de nuevo a la página predeterminada.
NetWorker Server está operativo. No hay impacto en las operaciones de protección de datos, solo el administrador de instalación no muestra el historial de instalación de NVE.
Cause
El avidb se corrompió. Hay muchas causas potenciales para problemas de espacio, problemas de actualización y acciones del usuario que pueden provocar esto. El enfoque de este artículo de la base de conocimientos es recuperar la funcionalidad.
Resolution
- Abra una sesión de SSH en el NVE e inicie sesión como administrador y, a continuación, cambie a root:
sudo su - - Antes de continuar, asegúrese de que no se observen problemas de espacio en el NVE. El avidb se encuentra en el punto de montaje /space:
df -h
df -h /usr/local/avamar/var/avi/server_data
Si algún volumen está cerca del 100 % de la capacidad. Se debe recuperar espacio antes de recuperar avidb
- Valide si
avidbLos respaldos están disponibles:mminfo -avot -q client=NVER-SERVER-NAME,name=/usr/local/avamar/var/avi/server_data
Ejemplo del mensaje de salida:
azure-nve:~ # mminfo -avot -q client=azure-nve.local,name=/usr/local/avamar/var/avi/server_data volume type client date time size ssid fl lvl name .... azure_nve.local.dddefault.002 Data Domain azure-nve.local 11/09/25 17:30:05 2868 KB 3977319918 cb full /usr/local/avamar/var/avi/server_data
- Detenga el proceso de avinstaller:
avinstaller.pl --stop - Asegúrese de que el proceso se haya detenido:
avinstaller.pl --test - Cambie el nombre del avidb actual si existe:
mv /usr/local/avamar/var/avi/server_data/avidb /usr/local/avamar/avidb_$(date -I).bak - Inicie sesión en NetWorker Management Console (NMC) o en la interfaz de usuario web de NetWorker (NWUI) para recuperar el
avidb.- Vaya a la pestaña Recuperar e inicie la recuperación.
- Ingrese el nombre del cliente NVE.
- Seleccione una fecha y, a continuación, seleccione la opción
/space/avamar/var/avi/server_data/y, a continuación, seleccione la carpetaavidbde NetWorker.
NOTA: Asegúrese de seleccionar una fecha de "último trabajo conocida". Si no se conoce una fecha específica, seleccione una fecha anterior a cuando apareció el problema sospechoso. En este artículo puedes ver tanto/usr/local/avamar/var/avi/server_data/avidby/space/avamar/var/avi/server_data/avidbReferencia. El NVE utiliza enlaces simbólicos y la ruta /usr se monta en /space.- Seleccione las opciones para recuperar a la ruta original y sobrescribir el archivo existente:
- Asigne un nombre e inicie el restaurador:

- Monitoree la restauración. La restauración debe mostrar que se realizó correctamente:

- Inicie avinstaller:
avinstaller.pl --start - Asegúrese de que avinstaller esté ejecutando lo siguiente:
avinstaller.pl --test - Inicie sesión en la página web de NetWorker Installation Manager y vaya a la pestaña History. Se muestra el historial de actualización de NVE (hasta el punto de recuperación de avidb):

avidb se recuperó; Sin embargo, los paquetes que se han instalado correctamente no se eliminan. Si intenta instalar el paquete nuevamente, se mostrará "Ya instalado". El historial de actualización de NVE también se puede encontrar en /usr/local/avamar/var/avi/server_data/package_data/.