NVE: NetWorker Installation Manager non mostra alcuna cronologia

Summary: NetWorker Virtual Edition (NVE) Installation Manager è accessibile da un web browser; Tuttavia, la scheda History non mostra alcun contenuto.

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Symptoms

Ci sono vari sintomi, una combinazione o tutti possono essere osservati.

  • "NetWorker Installation Manager" viene visualizzato come "Avamar Installation Manager".
  • Se si tenta di caricare un pacchetto di upgrade NVE (AVP) nel repository, viene restituito l'errore "Invalid Sysinfo".
  • NetWorker Installation Manager non mostra alcun contenuto nella scheda Cronologia. 
    Installation Manager NVE 

Potresti anche ricevere un avviso che dice "Server is not responding. You are now logged out of the Installation Manager" e vengono reindirizzati alla pagina predefinita.

Il server NetWorker è operativo. Non vi è alcun impatto sulle operazioni di protezione dei dati, solo Installation Manager non visualizza la cronologia di installazione di NVE.

Cause

Il file avidb è danneggiato. Esistono molte potenziali cause per problemi di spazio, problemi di aggiornamento e azioni da parte dell'utente che potrebbero causare questo problema. L'obiettivo di questo articolo della KB è restituire funzionalità.

Resolution

  1. Aprire una sessione SSH su NVE e accedere come amministratore, quindi passare a root: sudo su -
  2. Prima di procedere, accertarsi che non si osservino problemi di spazio su NVE. L'avidb si trova sul mount point /space:

df -h

df -h /usr/local/avamar/var/avi/server_data

Se un volume si avvicina al 100% della capacità. Lo spazio deve essere recuperato prima di ripristinare avidb

  1. Convalidare se avidb I backup sono disponibili: mminfo -avot -q client=NVER-SERVER-NAME,name=/usr/local/avamar/var/avi/server_data
NOTA: Sostituire NVE-SERVER-NAME con il nome del client NetWorker di NVE. Ad esempio, se il client NVE utilizza il nome di dominio completo (FQDN), utilizzare tale nome. Se il client NVE utilizza il nome breve, utilizzare tale nome. Il nome del client è visibile da NetWorker Management Console (NMC) o da NetWorker Web User Interface (NWUI) in Protection-Clients>.

Esempio di output:

azure-nve:~ # mminfo -avot -q client=azure-nve.local,name=/usr/local/avamar/var/avi/server_data
 volume        type   client           date     time         size ssid      fl   lvl name
....
azure_nve.local.dddefault.002 Data Domain azure-nve.local 11/09/25 17:30:05 2868 KB 3977319918 cb full /usr/local/avamar/var/avi/server_data
AVVERTENZA: È possibile ripristinare avidb solo se si eseguono processi di backup Server Protection-NVE> Server. Si tratta di una policy predefinita per gli NVE. Tuttavia, i backup devono essere gestiti dal Backup Administrator e resi disponibili. Senza questi backup, non è possibile ripristinare avidb.
  1. Arrestare il processo di installazione AVI: avinstaller.pl --stop
  2. Accertarsi che il processo sia stato arrestato: avinstaller.pl --test
  3. Rinominare l'avidb corrente, se presente: mv /usr/local/avamar/var/avi/server_data/avidb /usr/local/avamar/avidb_$(date -I).bak
  4. Accedere a NetWorker Management Console (NMC) o a NetWorker Web User Interface (NWUI) per ripristinare il avidb.
    1. Passare alla scheda Recover e avviare il ripristino.
    2. Inserire il nome del client NVE.
    3. Seleziona una data, quindi seleziona l'icona /space/avamar/var/avi/server_data/ , quindi seleziona l'icona avidb di NetWorker.
      Selezione del saveset avidb 
    NOTA: Assicurarsi di selezionare una data di "ultimo funzionamento noto". Se non è nota una data specifica, selezionare una data precedente a quando si è verificato il problema sospetto. In questo articolo vedete entrambi /usr/local/avamar/var/avi/server_data/avidb e /space/avamar/var/avi/server_data/avidb referenziato. NVE utilizza link simbolici e il percorso /usr viene montato su /space.
    1. Selezionare le opzioni per ripristinare il percorso originale e sovrascrivere il file esistente:
      Sovrascrittura di un file esistente 
    2. Assegnare un nome e avviare il restor:

Restore

  1. Monitorare il restore. Il ripristino dovrebbe mostrare che l'operazione è riuscita:

Sessione di ripristino

  1. Avviare il programma di installazione: avinstaller.pl --start
  2. Verificare che il programma di installazione av esegua: avinstaller.pl --test
  3. Accedere alla pagina web di NetWorker Installation Manager e passare alla scheda History. Viene visualizzata la cronologia degli aggiornamenti di NVE (fino al punto di ripristino di avidb):

NVE Installation Manager

NOTA: La scheda History non elenca i pacchetti che sono stati installati dopo la data a partire dalla quale il avidb è stato recuperato; Tuttavia, i pacchetti che sono stati installati correttamente non vengono rimossi. Se si tenta di installare nuovamente il pacchetto, verrà restituito "Already Installed". La cronologia degli aggiornamenti di NVE è disponibile anche in /usr/local/avamar/var/avi/server_data/package_data/.

Additional Information

Affected Products

NetWorker

Products

NetWorker Family
Article Properties
Article Number: 000390175
Article Type: Solution
Last Modified: 13 Nov 2025
Version:  4
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