Rodbrugeren kan ikke logge på WebUI/CLI i 8.x, når standarddomænet er angivet

Summary: Dubleret rodbruger i domænet forårsager problemer med at logge på klyngen via webbrugergrænsefladen og CLI.

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms

Når du logger på klyngen, mislykkes enten via WebUI eller CLI med adgangskodefejl.

Dette gælder for OneFS 8.x, når der er en dubleret bruger (f.eks. rod) på domænet.

Du kan stadig logge på med det unix_users domæne:

UNIX_USERS\root

Kontroller, om det pågældende domæne er indstillet til standarddomænet:

#isi auth ads view --provider-name=<domain> --verbose | grep "Assume Default Domain"
    Assume Default Domain: Yes

 

Cause

Hvis standarddomænet er indstillet, kontakter OneFS først domænet for at godkende den pågældende lokale bruger. I dette tilfælde bruger vi root. Hvis brugeren findes på domænet, forsøger OneFS at godkende brugeren via domænet.

Hvis kontoen er deaktiveret, vises der en fejlmeddelelse, når du forsøger at logge på.

 

Resolution

I 8.x kan du tilføje brugere, der ikke kan findes, til enhver domænecontroller ved hjælp af følgende kommando:

# isi auth ads modify --provider-name=<domain> --add-unfindable-users=<list of users we don't want found(to include domain name and FQDN) --restrict-findable=yes

For at sikre, at indstillingerne er foretaget, skal du køre godkendelsesvisningen igen:

# isi auth ads view --provider-name=<domain> --verbose
--you are looking for this output:
         Unfindable Users: <FQDN>\root, <Domain>\root, 0, root
          Findable Groups: -
           Findable Users: -
        Restrict Findable: Yes

Hvis klyngen skal sikre, at den filtrerer de brugere, der ikke kan findes, fra, skal Begræns findbar være slået til.

 

Article Properties
Article Number: 000050102
Article Type: Solution
Last Modified: 30 Jul 2025
Version:  4
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.