Isilon: Noden kan ikke starte med flere fejl, herunder "Dette system har 0 formateret startdisk". " og "UnbootableBootdiskException: 5".

Summary: Når en node, der påvirkes af BMC/CMC, hænger, som beskrevet i KB-artikel, 466373 genstartes uden først at frakoble begge netledninger og venter på, at den resterende strøm aflader, kan den muligvis ikke starte op med flere fejl, herunder "Dette system har 0-formateret startdisk". og "UnbootableBootdiskException: 5". IPMI-relaterede fejl ses også ofte i dette tilfælde. ...

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms


Når en node, der påvirkes af BMC/CMC, hænger, som beskrevet i KB-artiklen, 466373 genstartes uden først at frakoble begge netledninger og venter på, at den resterende strøm aflades, kan den muligvis ikke starte med et sæt fejl i stil med følgende:
 
<isi_rc> Executing script isi_bootdisk_init
python: Unable to open /var/run/mlx4_core0.vpd for writing: Read-only file system
Executing GEOM bootdisk startup...
python: Unable to open /var/run/mlx4_core0.vpd for writing: Read-only file system
This system has 0 formatted boot disk.
UnbootableBootdiskException: 5: Exception caught in startup attempt 1
Traceback (most recent call last):
  File "/usr/local/lib/python2.6/site-packages/isi/sys/bootdisk.py", line 1831, in startup
  File "/usr/local/lib/python2.6/site-packages/isi/sys/bootdisk.py", line 1741, in _startup
  File "/usr/local/lib/python2.6/site-packages/isi/sys/bootdisk.py", line 1657, in
handle_bootdisk_ids
  File "/usr/local/lib/python2.6/site-packages/isi/sys/bootdisk.py", line 1580, in
zero_bootdisks
UnbootableBootdiskException: 5
The system is unbootable.
python: Unable to open /var/run/mlx4_core0.vpd for writing: Read-only file system
2016-01-02T14:00:24-07:00 python: dbay_localbm: baymap unknown for chas 0 dskctl 8 portcount 8
2016-01-02T14:00:24-07:00 python: dbay_chascache_init: drive_bay doesn't know chassis Unknown, portcount 8
drive_bay doesn't know chassis Unknown, portcount 8
GEOM start failed

Hvis denne opstartsfejl skyldes en hængende BMC, viser en tidligere del af startsekvensen, at kernen ikke var i stand til at initialisere ipmi0-enheden korrekt (den sidste linje bør vise 4 i stedet for 0 under normale forhold):

ipmi0: Ryd flag for ipmi0
: Antal kanaler 0 

Cause

Et kendt BMC-firmwareproblem på HD400-, S210-, X210-, X410- og NL410-noder får nogle gange nodens BMC til at hænge. Når nodens BMC ikke svarer, kan OneFS ikke læse den EEPROM, der er tilsluttet CMC under opstart, for at finde ud af, hvilken type kabinet den kører på.  Hvis OneFS ikke kan bestemme kabinettypen, kan den ikke bestemme, hvordan du får korrekt adgang til startdrevene i den berørte node, og opstartsforsøget mislykkes.

Resolution

Der er en opdatering til BMC-firmwaren tilgængelig for at forhindre fremtidige forekomster af dette problem. men før den nye firmware kan anvendes, skal tilstanden med at gå i stå først afhjælpes. Du skal lukke noden (shutdown -p now), fjerne begge netledninger, vente et minut, tilslutte strømkablerne igen og bringe noden op igen. Du skal gentage denne strømcyklusproces op til tre gange for at rydde tilstanden, der hænger (holder op med at reagere). 

Når den ikke-reagerende BMC-tilstand er blevet ryddet, viser BMC-firmwareopdateringsprocessen, der er beskrevet i KB-artikel 466373 S210, X210, X410, NL410 eller HD400, hændelsen: "Nodens Baseboard Management Controller (BMC) og/eller Chassis Management Controller (CMC) reagerer ikke på det underliggende problem, der forårsager dette problem.

OPMÆRKSOMHED: Hvis ac-tænd/sluk-cyklus-proceduren, der er beskrevet i ovenstående KB, stadig ikke løser problemet efter tre forsøg, skal du kontakte EMC Isilons tekniske support og henvise til denne KB-artikel.

Affected Products

Isilon, Isilon HD400, Isilon NL410, PowerScale OneFS, Isilon S210, Isilon X210, Isilon X410
Article Properties
Article Number: 000052205
Article Type: Solution
Last Modified: 28 Jun 2023
Version:  6
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.