NVP-vProxy: VM backup fails "no matching devices for save of client `vCenter_Server_Name'; check storage nodes, devices, or pool"
Summary: NetWorker VMware Protection (NVP) Virtual Machine (VM) backups fail. The backup failure reported is "no matching devices for save of client `[VCENTER_SERVER]'; check storage nodes, devices, or pool" ...
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Symptoms
The NetWorker VMware Protection (NVP) integration is configured with the vProxy Appliance. One or more virtual machine backups are failing with the error noted below:
no matching devices for save of client `[VCENTER_SERVER]'; check storage nodes, devices or pool
The vCenter Server has a NetWorker Client resource configured in the NetWorker Management Console (NMC) Protection tab. The vCenter Server NetWorker Clients "Storage Nodes" attribute, under the "Globals (2 of 2)" tab, has the default blank settings.
Cause
The specific cause is unknown. Some of the virtual machines require the vCenter Server NetWorker Client "Storage Nodes" attribute to be configured with the appropriate Storage nodes.
Resolution
Update the vCenter Server NetWorker Client "Storage Nodes" attribute should be updated:
- Open the NetWorker Management Console.
- Select the Protection Tab.
- In the left side tree view, select "Clients."
- Select the vCenter server, right click, and select "Modify Client Properties."
- Go to the "Globals 2 of 2" tab
- Add the individual storage node names with the target backup devices for the vProxy backups. Include
nsrserverhost(default for NetWorker Server) as the last entry: (One server name per line)
For Example:
NW_SNode1.yourdomain.com NW_SNode2.yourdomain.com nsrserverhost
This modification will explicitly zone all the required devices, on the storage nodes that the vProxy backups use, as available to the vCenter server.
Affected Products
NetWorker, NetWorker Management Console, VMware vCenter ServerArticle Properties
Article Number: 000059477
Article Type: Solution
Last Modified: 22 Aug 2025
Version: 4
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