SourceOne index process ExAsIdxObj.exe crashes while indexing certain attachment files with non-Unicode file names

Summary: SourceOne index process ExAsIdxObj.exe crashes while indexing certain attachment files with non-Unicode file names

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms



Index set gets marked with "Missing item" status when certain files fail to index because ExAsIdxObj.exe crashes with error messages similar to following recorded in application event log of  SourceOne index server:
 

Log Name: Application Source: Application Error Date: 7/26/2017 11:38:38 AM Event ID: 1000 Task Category: (100) Level: Error Keywords: Classic User: N/A Computer: ES1Mixed.company.com Description: Faulting application name: ExAsIdxObj.exe, version: 7.2.4.4164, time stamp: 0x58984519 Faulting module name: ISYSpdf6.DLL, version: 11.4.0.2480, time stamp: 0x58f12255 Exception code: 0xc0000409 Fault offset: 0x00271e03 Faulting process id: 0x1754 Faulting application start time: 0x01d305b84568c186 Faulting application path: C:\Program Files (x86)\EMC SourceOne\EXPBA\bin\ExAsIdxObj.exe Faulting module path: C:\Program Files (x86)\EMC SourceOne\EXPBA\bin\ISYSpdf6.DLL Report Id: 86fbc812-71ab-11e7-9485-000c29ce130b Faulting package full name: Faulting package-relative application ID:


Crash of the ExAsIdxObj.exe process is seen on SourceOne native archive servers with index role where "Current Language for non-Unicode program" option from "Region and Language settings" is set to a non-English language e.g. Japanese and message in question has attachment that is not encoded in unicode and contains non-English characters.

Index set if submitted for rebuild also fails to rebuild due to error message mentioned above.

Cause

This problem is caused by software defect cited under SDR61286.

Resolution

This issue will be resolved in patches or Service Pack versions of EMC SourceOne Email Management post 7.2.SP5 (7.2.5.5088). DELL EMC SourceOne Patch and Service Pack kits are available for download via http://support.emc.com. 

If your site is running into this issue before release containing fix is available, please contact DELL EMC Technical Support, share support note article and SDR number (61286) with your support representative.

Affected Products

SourceOne Email Management

Products

SourceOne, SourceOne Email Management
Article Properties
Article Number: 000167206
Article Type: Solution
Last Modified: 02 Sept 2025
Version:  6
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