「PowerStore:システム ヘルス チェックでcyc_node内のスペース不足が検出される
Summary: システム ヘルス チェックで、/cyc_nodeに200 MB未満が検出されました。未解決のままにしておくと、予期しないノードの再起動イベントが発生したり、ノードがサービス モードに入ったりする可能性があります。
Symptoms
システム ヘルス チェックでは、次のようなメッセージが表示される場合があります。
/cyc_node free space is less than 200 MB. (KB#000198173)
または
Unable to parse passed url (0xE04040020008)
システムは、次のような通常のアラートを表示する場合があります。
Root partition usage of node x has exceeded xx% on mount /cyc_node.
- このアラートまたは問題は無視できず、できるだけ早く解決する必要があります。
- システム ヘルス チェックでこの状態が検出された場合、PowerStoreOSのアップグレードが失敗し、予期しない再起動のリスクが生じます。
- パーティションが100%に達すると、SupportAssistが失敗し、ノードがサービス モードに入ることがあります。
次の例では、アプライアンスの両方のノードに十分なスペースがありません。 /cyc_nodeの詳細を確認してください。
- PowerStore Managerで[Run Upgrade Extensions]オプションを使用したシステム チェックの実行:
![[Run Upgrade Extensions]オプションでPowerStore Managerを使用してシステム チェックを実行するGUIのスクリーン ショット](https://supportkb.dell.com/img/ka0Do000000ErtYIAS/ka0Do000000ErtYIAS_ja_3.jpeg)
ヒント:[Run Upgrade Extensions]オプションを使用してシステム チェックを実行すると、[Profile]フィールドに[Upgrade Extensions]と表示されます。
- PowerStore Manager (UI)で[Run System Check]オプションを使用してシステム チェックを実行する:
![PowerStore Manager (UI)で[Run System Check]オプションを使用してシステム チェックを実行するGUIのスクリーン ショット:](https://supportkb.dell.com/img/ka0Do000000ErtYIAS/ka0Do000000ErtYIAS_ja_4.jpeg)
ヒント:[Run System Check]オプションを使用してシステム チェックを実行すると、[Profile]フィールドに[Service Engagement]が表示されます。
- を使用したシステム正常性サービス スクリプト(svc_health_check)の実行
SSH接続:
$ svc_health_check run -rhc cyc_node_space_check Name Location Status Description cyc_node space check node_a FAILED /cyc_node free space is less than 200MB. (KB#000198173) cyc_node space check node_b FAILED /cyc_node free space is less than 200MB. (KB#000198173)
エラーの例:
"Unable to parse passed url"
Cause
このアラートにリンクされている一般的なシナリオは次のとおりです。これらのシナリオは、 svc_partition_cleanup service スクリプト:
- Article # 000202707 PowerStore: /cyc_cfsの領域不足によりアップグレード前ヘルス チェックが失敗する
- Article # 000193605 PowerStore: データ コレクションが失敗してPowerStore Managerユーザー インターフェイスが誤った情報を報告する
- Article # 000324110 PowerStore Alerts: ノードXのrootパーティションの使用率がマウント/で91%を超えました。
- Article # 000202949 PowerStore: Dell SupportAssistデータベースがいっぱいになり、内部パーティションがいっぱいになり、アップグレードの失敗またはノードの再起動が発生する可能性があります」
- Article # 000223342 PowerStore: マウント/cyc_nodeの断続的なアラート コード0x00400601と0x00400602
- Article # 000328471 PowerStore: ルート パーティションの使用率が急速に増加している
Resolution
パーティションがいっぱいになる原因のほとんどは、PowerStoreOS LTS-v4.1.xで解決されています。現在の状態を解決したら、PowerStoreアプライアンスをPowerStoreOS LTS-v4.1.x以降にアップデートします。
対策
以前のバージョンでは、両方のノードが通常モードの場合、SupportAssistを一時的に無効にすることができます。通常、これにより「/cyc_node.
SupportAssistを無効にする前に、PowerStoreがPowerStoreに公開されていないことを確認します。データ コレクションが失敗してPowerStore Managerユーザー インターフェイスが誤った情報を報告する」の状況になっていないことを確認します。PowerStoreでこの問題が発生していると思われる場合は、次の手順に進む前に、まずこの問題を解決してください。
PowerStore Managerユーザー インターフェイス(UI)からSupportAssistを無効にする手順
-
設定>サポート接続>接続タイプ>[Disable] に切り替えて [Apply] をクリックします。
SupportAssistが無効になっていることを確認します。ジョブが完了したように見えたら、UIページを更新して、無効または有効と表示されているかどうかを確認します。- 何度か試行しても有効と表示され、UIからSupportAssistを無効にしても機能しなかった場合は、手順5に進みます。
- UIページの更新後に無効と表示される場合は、手順2に進みます。
- 少なくとも15分待ちます。
- SupportAssistを再度有効にします。
注:SupportAssistの有効化に失敗した場合でも、このパーティションをリセットして領域をクリアするだけで十分です。SupportAssistを有効にできない場合は、通常のトラブルシューティングを実行する必要があります。
- 確認
/cyc_nodePartition overSSH次のコマンドを使用します。
df -h
- 問題が解決しない場合は、次のセルフサービス アクションとして、
svc_partion_cleanupルート パーティションをクリーンアップするサービス スクリプト。
- 一般的なインストール手順: Article # 000371058 PowerStore: svc_injectableサービス スクリプトをインストールする方法 (この記事を表示するには、登録済みのDellサポート ユーザーとしてログインする必要がある場合があります)。
- svc_partition_cleanup手順: Article # 000214954 PowerStore: 挿入可能なサービス スクリプト svc_partition_cleanupを実行してパーティション/cyc_node、/cyc_var、/cyc_cfsをクリーンアップする方法(この記事を表示するには、登録済みのDellサポート ユーザーとしてログインする必要がある場合があります)。
- システム ヘルス チェックまたはアップグレード前ヘルス チェックを再試行して、問題が解決されたことを確認します。
- これでも問題が解決しない場合は、Dellテクニカル サポートまたは認定サービス担当者にお問い合わせいただき、この記事IDをお伝えください。
Additional Information