ECS 서비스 콘솔: "Validate Node hostname" "Check DNS Settings" Fail with Case Mismatch(대소문자 불일치로 실패)

Summary: DNS(Domain Name System) 호스트 이름 간의 대/소문자 불일치로 인해 "노드 호스트 이름 검증" 또는 "DNS 설정 확인"에 대한 ECS 서비스 콘솔 확인이 실패합니다.

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms

노드의 호스트 이름이 DNS에 있는 이름과 일치하지 않으면 서비스 콘솔이 오류를 기록합니다. 이 검사는 대/소문자를 구분합니다.

불일치가 있는 각 노드에 대해 다음 오류가 기록됩니다. 
20220101 12:00:00.000: Validate Node hostname
[ERROR] The hostname on node 169.254.1.1 is 'ecsnode01.dell.com' and the fqdn from the ini file is 'ECSNODE01.dell.com' - they do not match
DNS 설정 확인과 정방향 및 역방향 테스트의 DNS 결과에는 대/소문자를 구분하는 차이가 있습니다. 이 예를 참조하십시오. ECSNODE01.dell.com 대 ecsnode01.dell.com
20231108 09:31:22.270: |   | FAIL
[ERROR] 'Check DNS settings' failed: Could not find 'ECSNODE01.dell.com' in 'nslookup 10.0.0.1' output. Node: 169.254.1.1
10.0.0.1.dell.com = ecsnode1.dell.com.

Authoritative answers can be found from:

Cause

ECS 노드 호스트 이름은 DNS에 있는 호스트 이름과 정확히 일치해야 합니다. 여기에는 정방향 및 역방향 조회 영역이 모두 포함됩니다. 이 검사는 대/소문자를 구분합니다.

Resolution

정방향 및 역방향 영역 DNS가 호스트 이름과 정확히 일치하는지 확인합니다. 

이 예에서 정방향 및 역방향 DNS만 대/소문자를 구분하여 다르므로 알림이 생성됩니다. 

이 예에서 호스트 이름은 "ecsnode01.Dell.com:" 

admin@ecsnode01:~> hostname -f
ecsnode01.dell.com

다음을 사용하여 사용자 시스템에서 Forward DNS를 확인합니다. nslookup 노드의 FQDN: 

admin@ecsnode01:~> nslookup ecsnode01.dell.com
Server:         192.1xx.2xx.254
Address:        192.1xx.2xx.254#53

Non-authoritative answer:
Name:   ecsnode01.dell.com
Address: 10.0.0.1

이 예에서 정방향 DNS 조회는 호스트 이름과 일치합니다. 둘 다 모두 소문자입니다.

다음을 사용하여 사용자 시스템에서 역방향 DNS를 확인합니다. nslookup 노드의 IP 주소:

admin@ecsnode01:~> nslookup 10.0.0.1
1.0.0.10.in-addr.arpa       name = ECSNODE01.dell.com.in-addr.arpa.

Authoritative answers can be found from:

이 예에서 역방향 DNS 조회는 호스트 이름에 대해 대문자를 반환합니다. 역방향 DNS 영역은 시스템의 호스트 이름과 일치하도록 소문자로 업데이트해야 합니다. 

이 문제를 해결하려면 ECS의 FQDN을 변경할 수 없으므로 DNS 서버의 항목을 변경합니다. 이 문제: 호스트 이름과 일치하도록 DNS를 업데이트해야 합니다. 호스트 이름, 정방향 DNS 조회 또는 역방향 DNS 조회 간에 불일치가 발생하면 이 오류가 발생합니다. 

사용자 조치:
문서 80094: ECS: ECS 노드의 외부 또는 FQDN(Public Name) 또는 공용 IP 주소 변경이 지원됩니까?


사전 업그레이드 검사의 일부로 탐지된 경우:

20231107 12:51:45.771: |   Check DNS settings
20231107 12:51:46.248: |   | FAIL
[ERROR] 'Check DNS settings' failed: Could not find 'ECSNODE1.ch.net.intra' in 'nslookup 10.0.0.1' output. Node: 169.2xx.1.1
10.0.0.1.in-addr.arpa name = ecsnode1.ch.net.intra.

Authoritative answers can be found from:

대/소문자를 구분하는 차이로 인해 잘못된 알림일 수 있으며 대/소문자를 구분하는 경우에만 다른 경우 업그레이드가 차단되지 않습니다.

노드에 대해 다음 검사를 실행하여 대/소문자를 구분하는 차이인지 확인합니다.

admin@ECSNODE1:~> hostname
ECSNODE1.ch.net.intra


admin@ECSNODE1:~> hostname -f
ECSNODE1.ch.net.intra


admin@ECSNODE1:~> hostname -i
10.0.0.1

admin@ECSNODE1:~> nslookup ECSNODE1
Server:         192.1xx.2xx.254
Address:        192.1xx.2xx.254#53

Non-authoritative answer:
Name:   ECSNODE1.ch.net.intra
Address: 10.0.0.1

admin@ECSNODE1:~> nslookup ecsnode1
Server:         192.1xx.2xx.254
Address:        192.1xx.2xx.254#53

Non-authoritative answer:
Name:   ecsnode1.ch.net.intra
Address: 10.0.0.1

admin@ECSNODE1:~> nslookup 10.0.0.1
1.88.96.10.in-addr.arpa name = ecsnode1.ch.net.intra.

Authoritative answers can be found from:

admin@ECSNODE1:~>

검색된 유일한 차이가 대소문자인 경우 사전 업그레이드 확인에서 잘못된 알림입니다.

Affected Products

ECS, ECS Appliance
Article Properties
Article Number: 000203965
Article Type: Solution
Last Modified: 02 Jul 2025
Version:  11
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.