Asset sizes Not showing up in the UI for SQL database backups

Summary: After SQL Backups run Successfully, and then viewing the SQL Assets, some of the databases are not reporting the Size. The sizes are empty.

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms

Screenshot below shows that database sizes are circled in Orange, but no sizes are shown for several of the databases with the Green Arrow. 
 
Screenshot of Assets with green arrows indicating databases but no sizes are included

Cause

You must ensure that database OS account or NT AUTHORITY or SYSTEM account that is being used on each SQL host has the required sysadmin privilege. By default, the Microsoft application agent uses the SYSTEM account for asset discovery and this requires granting the SYSTEM account the Microsoft SQL Server sysadmin role.

Resolution

Setting the sysadmin privilege for database OS account:

Complete the following steps to ensure that the database OS account on each host has the sysadmin privilege.
  1. Log in to each Microsoft SQL Server instance > open SQL Server Management Studio (SSMS) > select View > Object Explorer.
  2. Go to Object Explorer > expand Security > expand Logins.
  3. Right-click the Database OS Account Name, and then select Properties.
  4. In the Login Properties window, select Server Roles.
  5. Select sysadmin under Server Roles.
  6. Click OK. The Login properties window closes.
  7. On the PowerProtect Data Manager UI, select Infrastructure > Asset Sources > select SQL tab.
  8. Select the required Hostname in the list, and then click Edit Credentials.
  9. On the Set Credential page, specify the Database OS credentials, and select the option Use the credentials for both asset discovery and backup.
    NOTE: On the Set Credential page, the option Use the credentials for both asset discovery and backup does not appear when the database OS credentials setting is None or the application agent release is before 19.11.
  10. Click Save.


Setting the sysadmin privilege for NT AUTHORITY\SYSTEM account

Complete the following steps to ensure that the NT AUTHORITY\SYSTEM account on each host has the sysadmin privilege.
  1. Log in to each Microsoft SQL Server instance > open SQL Server Management Studio (SSMS) > select View > Object Explorer.
  2. Go to Object Explorer > expand Security > expand Logins.
  3. Right-click NT AUTHORITY\SYSTEM, and then select Properties.
  4. In the Login Properties window, select Server Roles.
  5. Select sysadmin under Server Roles.
  6. Click OK. The Login properties window closes.

Additional Information

If this does not comply with security requirements as an alternative, you can select the option 'Use the credentials for both asset discovery and backup' which uses a domain or local user account instead for the Asset Discovery. 

This option can be selected on the 'Set Credential' page in the PowerProtect Data Manager UI.
 
Screenshot of Set Credentials page in PPDM
 
More details are seen in Chapter 3: Managing Storage, Assets, and Protection, of the PowerProtect Data Manager 19.13 SQL User Guide.

Affected Products

PowerProtect Data Manager Appliance, PowerProtect Data Manager Software, PowerProtect DM5500
Article Properties
Article Number: 000215752
Article Type: Solution
Last Modified: 28 Jul 2023
Version:  2
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