Ressourcengrößen werden in der Benutzeroberfläche für SQL-DB-Backups nicht angezeigt

Summary: Nachdem SQL-Backups erfolgreich ausgeführt wurden und dann die SQL-Ressourcen einiger Datenbanken angezeigt werden, wird die Größe nicht angezeigt. Die Größen sind leer.

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms

Der Screenshot unten zeigt die in Orange hervorgehobenen Datenbankgrößen, für mehrere Datenbanken mit dem grünen Pfeil werden jedoch keine Größen angezeigt.

339-Stephen-Asset-Sizes-edit2.PNG
 

Cause

Es muss sichergestellt werden, dass das Datenbankbetriebssystemkonto oder das NT AUTHORITY/SYSTEM-Konto, das auf jedem SQL-Host verwendet wird, über die erforderliche Sysadmin-Berechtigung verfügt. Standardmäßig verwendet Microsoft Application Agent das SYSTEM-Konto für die Ressourcenerkennung, was erfordert, dass dem SYSTEM-Konto die Microsoft SQL Server-Sysadmin-Rolle gewährt wird.

Resolution

Festlegen der sysadmin-Berechtigung für das Datenbankbetriebssystemkonto
Führen Sie die folgenden Schritte aus, um sicherzustellen, dass das Datenbankbetriebssystemkonto auf jedem Host über die Sysadmin-Berechtigung verfügt.
1. Melden Sie sich bei jeder Microsoft SQL Server-Instanz an, öffnen Sie SQL Server Management Studio (SSMS) und wählen Sie View > Object
Explorer aus.
2. Erweitern Sie im Objekt-Explorer die Option Sicherheit und erweitern Sie dann Anmeldungen.
3. Klicken Sie mit der rechten Maustaste auf den Namen des Datenbank-BS-Kontos und wählen Sie eigenschaften aus.
4. Wählen Sie im Fenster Anmeldeeigenschaften die Option Serverrollen aus.
5. Wählen Sie sysadmin unter Server roles aus.
6. Klicken Sie auf OK.
Das Fenster Anmeldeeigenschaften wird geschlossen.
7. Wählen Sie in der Benutzeroberfläche von PowerProtect Data Manager Infrastructure > Asset Sources aus und wählen Sie dann die Registerkarte SQL aus.
8. Wählen Sie den erforderlichen Hostnamen in der Liste aus und klicken Sie dann auf Edit Credentials.
9. Geben Sie auf der Seite Set Credential die Anmeldedaten für das Datenbankbetriebssystem an und wählen Sie die Option Use the credentials for asset
discovery and backup aus.
HINWEIS: Auf der Seite Set Credential wird die Option Use the credentials for asset discovery and backup nicht
angezeigt, wenn die Einstellung für die Datenbankbetriebssystem-Anmeldeinformationen None ist oder die Version des Anwendungs-Agent älter als 19.11 ist.
10. Klicken Sie auf Speichern.

Festlegen der sysadmin-Berechtigung für das Konto
NT AUTHORITY\SYSTEMFühren Sie die folgenden Schritte aus, um sicherzustellen, dass das KONTO NT AUTHORITY\SYSTEM auf jedem Host über die Sysadmin-Berechtigung verfügt.
1. Melden Sie sich bei jeder Microsoft SQL Server-Instanz an, öffnen Sie SQL Server Management Studio (SSMS) und wählen Sie View > Object
Explorer aus.
2. Erweitern Sie im Objekt-Explorer die Option Sicherheit und erweitern Sie dann Anmeldungen.
3. Klicken Sie mit der rechten Maustaste auf NT AUTHORITY\SYSTEM und wählen Sie Eigenschaften aus.
4. Wählen Sie im Fenster Anmeldeeigenschaften die Option Serverrollen aus.
5. Wählen Sie sysadmin unter Server roles aus.
6. Klicken Sie auf OK.
Das Fenster Anmeldeeigenschaften wird geschlossen.

Additional Information

Wenn dies nicht den Sicherheitsanforderungen entspricht, können Sie alternativ die Option "Use the credentials for asset discovery and backup" auswählen, die stattdessen eine Domain oder ein lokales Benutzerkonto für die Ressourcenermittlung verwendet. 
Diese Option kann auf der Seite "Set Credential" in der PPDM-Benutzeroberfläche ausgewählt werden.
 
341-kb-set-credentials-snip.PNG
Weitere Details auf Seite 49 des PPDM 19.13 SQL-Benutzerhandbuchs

Affected Products

PowerProtect Data Manager Appliance, PowerProtect Data Manager Software, PowerProtect DM5500
Article Properties
Article Number: 000215752
Article Type: Solution
Last Modified: 28 Jul 2023
Version:  2
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.