PowerEdge: 16G server fails UEFI iSCSI BFS on Dell PowerStore appliance with CHAP authentication enabled

Summary: Dell 16G PowerEdge servers fail UEFI iSCSI boot from SAN with PowerStore appliance when enabling CHAP authentication.

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms

Deploying uEFI Boot From SAN (BFS) over iSCSI networking on Dell PowerEdge servers to a Dell PowerStore appliance with CHAP authentication enabled.
The server console displays messages during POST indicating that iSCSI boot cannot proceed due to CHAP login failure.
Server POST error message
This issue occurs on both Dell 16G Intel and AMD platforms, with various BIOS versions. The Dell PowerStore appliance that experiences this issue can also operate on multiple versions of PowerStoreOS.


 

Cause

PowerStore appliance wrongly chooses "CHAP_A=7" as its support algorithm, and then tries to use SHA1 algorithm to decode the CHAP response codes which 16G BIOS encodes using SHA256. It causes final CHAP authentication failure.

Resolution

Upgrade PowerStoreOS to version 3.6.1.0-2261541 or newer to resolve.

Affected Products

PowerEdge R6615, PowerEdge R6625, PowerEdge R760, PowerEdge R7615, PowerEdge R7625, PowerStoreOS
Article Properties
Article Number: 000223452
Article Type: Solution
Last Modified: 20 Jan 2025
Version:  2
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.