VxRail: Agenta vSphere HA nelze nainstalovat ani nakonfigurovat, selže s chybou: Odmítnuté heslo pro uživatele vpxuser

Summary: VxRail: Agenta vSphere HA nelze nainstalovat ani nakonfigurovat.

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms

Uzel není v nástroji vCenter k dispozici.
Chyby v systému vCenter for ESXi:
Cannot complete login due to an incorrect username or password
vSphere HA agent cannot be installed or configured
Zákazník vrátil zpět nástroj vCenter kvůli problému s pokusem o upgrade některých uzlů v clusteru. Uzly a virtuální počítače již nejsou spravovány nástrojem vCenter.
VXR014030 ALARM Check vSphere HA host status
Vsphere HA host status
Cannot synchronize host …………….

  Obrázek chyby VXR014030 ALARM Kontrola stavu hostitele vSphere HA
hostd.log
Rejected password for user vpxuser from XXX.XX.XX.XX (ip address) 
Obrázek chyby se zamítnutým heslem pro uživatele vpxuser z XXX.XX.XX.XX (ip adresa)
Virtuální počítače na uzlu jsou stále spuštěné. Stav sítě vSAN v rozhraní příkazového řádku hlásil všechny testy zeleně.
 esxcli vsan health cluster list
 
 
 

Cause

K tomuto problému dochází, když je heslo vpxuser uložené v mezipaměti na hostiteli nesprávné nebo vypršela platnost vašeho účtu v nástroji vCenter Server.
Tento hypertextový odkaz vás zavede na webové stránky mimo společnost Dell Technologies.
https://knowledge.broadcom.com/external/article?legacyId=2097171Uživatel vpxuser je uživatel vygenerovaný v systému ESXi nástrojem vCenter po přidání uzlu a opětovném připojení k nástroji vCenter.

Resolution

Chcete-li tento problém vyřešit, odpojte a připojte hostitele namísto použití kroku "Odebrat z inventáře" uvedeného v článku znalostní databáze VMware výše.

Poznámka: V KB2097171 zahrnuje odebrání uzlu z inventáře. Odebrání uzlu z inventáře vCenter je ve srovnání s možností odpojení a opětovného připojení invazivnější úlohou.
V některých situacích může mít zákazník na uzlu stále spuštěné virtuální počítače. Tyto virtuální počítače nemusí být možné migrovat nebo zaregistrovat na jiném uzlu z důvodu stavu nespravovaného systému ESXi.
Když je hostitel odebrán z inventáře, je zcela odebrán ze správy vCenter a účasti v síti vSAN. Před odebráním je nutné vypnout všechny virtuální počítače. Jakmile je uzel mimo nástroj vCenter, je nutné virtuální počítače zaregistrovat do nového uzlu, aby se mohly zapnout. Pro srovnání, když je hostitel odpojen od nástroje vCenter, bude se i nadále účastnit sítě vSAN. Všechny virtuální počítače v uzlu nadále běží bez problémů, i když je hostitel odpojený. 

Poznámka: Při odpojení spravovaného hostitele se dočasně pozastaví všechny aktivity monitorování, které nástroj vCenter Server provádí. Spravovaný hostitel a jeho přidružené virtuální počítače zůstávají v inventáři vCenter Serveru. Tento hypertextový odkaz vás zavede na webové stránky mimo společnost Dell Technologies. https://docs.vmware.com/en/VMware-vSphere/7.0/com.vmware.vsphere.vcenterhost.doc/GUID-DE06875C-CB8C-442E-AC1D-24BFFA3F6705.htmlPokud uzel nelze znovu připojit kvůli dalšímu problému se službou, je nutné vypnout všechny virtuální počítače a restartovat je, abyste se mohli pokusit o opětovné připojení. 


Postup: 
  • Odpojení uzlu od nástroje vCenter https://docs.vmware.com/en/VMware-vSphere/7.0/com.vmware.vsphere.vcenterhost.doc/GUID-DE06875C-CB8C-442E-AC1D-24BFFA3F6705.htmlTento hypertextový odkaz vás zavede na webové stránky mimo společnost Dell Technologies.
  • Otevřete relaci SSH pro dotčený uzel:
  • Zastavte službu níže: (Tato služba musí být zastavena před zahájením úlohy opětovného připojení) 
    /etc/init.d/vpxa stop
  • Odeberte účet:
    esxcli system account remove -i vpxuser
  • Potvrďte, že účet není k dispozici: 
    esxcli system account list
  • Vraťte se do uživatelského rozhraní vCenter a připojte hostitele (na pozadí se zobrazí chyby uživatele a hesla, takže pokračujte v průvodci).
  • Dokončete průvodce a uzel by mělo být opět možné spravovat z nástroje vCenter.
 

Affected Products

VMware ESXi 6.7.X, VMware ESXi 7.x, VMware vCenter Server
Article Properties
Article Number: 000225410
Article Type: Solution
Last Modified: 28 May 2024
Version:  1
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.